Buffer Size Issue

Hi guys,

I’m having a problem, I’m not exactly sure whats causing it and I was hoping somebody on here might know.

Basically, when playing back any audio through cubase unless I set the buffer size to 4k it sounds distorted and nasty. Even at 4k there are still many artefacts, pops and clicks. If I export the audio track it appears to be absolutely fine, its just simply playing back audio in Cubase.

It’s strange because in Pro Tools 8.0.4 there is absolutely no problem. I’ve tried changing clock source and all buffer sizes with no luck. I’m pretty sure it’s related to the M-Box drivers in some way but I’m not sure how. I’ve had nothing but trouble with my M-Box but I need it for Pro Tools.

Thanks in advance,


Does that come with ASIO drivers? If not, you might have luck with a universal driver from ASIO4ALL.

Also, what bit-rate and sample rate are you running at?

Thank you innerlyte for your reply.

The M-Box 2 comes with its own ASIO drivers, there built into the Pro Tools software. This is where things become quite problematic. The M-Box 2 supports up to 48k sample rate and 24bit depth. However, if I select a sample rate of 48k in Pro Tools then I get an unwanted static fuzz untill I shut my computer off at the wall for about 5 minutes.

This is driver related I’m sure. Unfortunately the support for windows 7 64bit has been unstable ever since I got the M-Box 2 back in January. Back in July they released drivers that do work but only at 44k.

When opening a session in Cubase I am not prompted to set the sample rate and size. If I go into Device setup I can see that the VST audio system driver is set to “ASIO Digidesign Driver Mbox2” so I presume its operating under the same settings.

Does that shed any light on the situation?





Hi Caatalyst,
since this is not a cubase issue, i guess this is most probably why no one has been able to help.
can you get your m-box to work with protools? Are problems related only to 48k, does it perform well in 44.1k? Are you able to open the m-box control panel from within cubase Devices>Device Setup> VSt AudioSystem…and see its settings?
finally, have you tried the asio4all solution that innerlyte suggested for reference issues?

Hi Manakesna,

thanks for the reply.

The buffer size issue does not occur in Pro Tools, only Cubase. I’ve tried accessing cubase Devices Vstaudiosystem and manually changing the buffer size there which makes no difference unless I set it to 4k. The audio becomes audible but still poor.

I haven’t tried asio4all because I presume that means I won’t be able to use my M-Box interface as it has its own drivers?

It’s probably worth trying ASIO4ALL it should see your mbox and wont interfere with the Mbox asio drivers.

ASIO4all should work with most soundcards, any drivers installed are irrelevant. It’s worth a shot at least, can’t see how it could harm your current setup.

I’ll give it ago tomorrow and get back to you guys thanks!

Well I’ve installed the ASIO4all drivers but when I select them in cubase>Device Setup they successfully load. However, when I return to the session and hit play, nothing is coming out of the master fader. I’ve tried playing around with the ASIO4all settings but it doesn’t seem to make a difference. If I revert back to the M-Box drivers everything plays back fine except with the original problem.

Recently I got my hands on a mbox2 and was keen to see how it performed compared to my prersonus 1394. Aside from the whole annoyance of having to install protools just to make it work, it’s latency was terrible. If you set the buffer to 128 it’s ok (approx 12ms) but as soon as you get a few things running it soon starts to pop and crackle and then you have to drop it back to 4096 at which point latency goes up to around 90ms ! On the same project the presonus will run happily without pops at 12ms.