Buffers Below 128 Cause Pops and Crackles with Intel Turbo Mode Enabled

I haven’t used low latency for awhile but was playing an amp sim in Cubase 10.0.30 (10.0.50 is currently unusable for me) and there are pops and crackles with any buffer under 128. The ASIO meter isn’t showing any overloads though. So I did some searching and found another user that had issues and fixed them by disabling Intel Turbo Boost. So I did that and it actually fixed it but now my overclock settings are ignored so I lose quite a bit of power.

I did test with multiple audio cards. I also tried a stand alone guitar amp at 32 samples and it worked fine. I’m not a Reaper user but I downloaded it to test. Reaper does not display this issue as Cubase does.

Just to be clear, my CPU isn’t set to fluctuate speeds at all. Turbo mode just has to be on so it knows to run all cores at 4Ghz instead of 2.8Ghz. Speedstep is disabled. Cubase appears to be the only application giving me problems with this. Anybody else experience something similar?


I would recommend to run LatencyMon utility to check your system.

Just gave that a try. Nothing showing as an issue with latency monitor. I even brought up Cubase while running latency monitor. I ran at 32 samples and heard the pops and clicks but latency monitor showed no problems during that.

I’m on the latest revision of Windows 10. It does appear to have something to do with Intel Turbo Boost even if I’m not actually having the speed fluctuate as Turbo Boost normally does. Maybe it has something to do with high core count CPU’s that have Turbo Boost. It is definitely a Cubase issue though on my system at least since it is the only application displaying this behavior.

So I’m stuck at the crossroads of either disabling Turbo Boost (and my overclock) or just running at higher buffer settings if I want to use Cubase.

Did some more investigating. If I disable multi core processing in Cubase it no longer has pops and clicks. Must have something to due with the high core count Skylake-X chips like I have.

To note also, I tried out Studio One and observed no issues at a 32 sample buffer so it is definitely something with Cubase.

Another note, I’ve been using Cubase since SX3 as my main host. I’m really not looking to switch since I’m not interested in relearning stuff I already know how to do in Cubase. Plus Cubase is fast as far as me getting things done within it. So, I’m currently kind of frustrated but will hope that a future update cures whatever is wrong.

I just want to report that after doing a full fresh new installation of the latest windows 10 that I can play black a full session at 32 samples with no issues. Must have been something through the windows update process over the year time frame or something. Either way, now it is rock solid again.


Very valuable information. Thank you for sharing this.