[BUG] 4.5.3 update and RX2/Slice player mappings

I have been on the 4.5.3 update since its release date, but only just came across this new issue today. I was finishing up projects created on earlier versions of Halion 4.5, which did not exhibit this behavior. Only upon creating a new project, did this issue show itself.

The problem is with the way the 4.5.3 update handles RX2 files loaded into slots.

In previous versions of Halion 4.5, if an RX2 file was loaded into a slot, it created a new file as follows:

drumloop_halimported

This would show up in the program tree of the selected slot, with all slices listed underneath it and an output bus at the end in which this all connected to.

In the current 4.5.3 release, if an RX2 file is loaded into the slot, it not longer creates the halimported file. All slices are listed underneath, but it creates NO output bus in which all slices are routed to. This is not the normal, expected behavior and makes it very odd to work without an output bus which should normally be there like it always has. Creating an output bus manually, is not the same and does not appear to be connected in the same manner. If I load a project which already had an RX2 loaded from an earlier 4.5 release of Halion and then import a new RX2 into a fresh slot and compare the program tree of them both side by side, they are clearly different in the way they are mapped out.

This is totally new to me and I have never noticed this behavior in previous Halion 4.5 releases, it seems to be occurring just after the 4.5.3 release.

Can anyone confirm?

I can confirm that the auto slicing doesn’t create an output. I haven’t been using rex files for the reason you outlined in your other thread. So, I can’t confirm it used to do so. However, if you drag a wav it does create a program bus automatically. That would be the expected behavior if you ask me.

Confirmed here also, though Like JMCeciI I also can’t confirm if this is a change, as I usually drag REX straight to the Program Tree. Possibly a visual glitch, as there is obviously a bus existing internally (otherwise you wouldn’t hear anything) but it’s just not visible. Odd indeed.

no that buss is the master. The typical patch buss is not there.

Thanks a lot guys for all your time in replicating this. This is not the expected behavior at all and as a very avid user of RX2 files, I noticed this change right away, when compared to how it worked in previous Halion 4 releases. The creating of an output bus like it does for WAV files is the expected behavior. The fact that no halimported listing shows, is also the dead giveaway.

Can anyone at Steinberg look into this and issue a fix please?

Thanks again to all who took time to look into this for me.

I know things are busy over there with the Cubase 7 launch today, but has anyone at Steinberg officially seen this and care to comment? Can this be confirmed on your end, like it has with the various users here, that something has changed with this latest update and the expected behavior is not what is actually taking place when compared to previous Halion 4 releases?

This is not isolated to Cubase 6.5, or 32 bit. I just purchased and installed Cubase 7 64 bit and Halion 4.5.3 64 bit and I am still getting this same ‘issue’. I can see now that a folder named wav is created and the wav extraction of the RX2 is placed in said folder. That would probably explain why there is no more halimported tag associated with the wav extraction. This must be a behind the scenes change Steinberg deliberately did, but it wasn’t mentioned in the changelog. An output bus is still not created however, like one would expect from every other sample type that is loaded into Halion 4.

The silently released 4.5.4 update does not fix this problem, though I never expected it to since it was dated to have been built on Nov. 30, despite being released only this week!! The only mentioned fix was for problems opening Cubase 7.0.0 projects, something I never experienced personally.

Anyways, since this has received no attention and therefore no fix, I am bringing it up again, this time with an attached screen shot to show what I mean. This was a straight drag and drop of an RX2 file into a blank slot in Halion 4.5.4 (this bug was introduced in 4.5.3 and was not present in earlier builds). This happens from within Mediabay, the sampler browser, Windows Explorer etc. It makes no difference. The sample imports as should, however, no output bus is created like it should. All other sample types properly create an output bus to go along with the newly created program, including RX2 files in builds prior to 4.5.3. This should really be remedied, as something has gone wrong in the latest updates, I assume with the way the Slice player handles the extracted WAV files from the RX2 files in the newly created ‘wav’ folder, instead of amending ‘Halimported’ on the end of the wav file like previous Halion 4 versions did when loading an RX2 file.
Halion 4.5.x Slice player bus bug.jpg