BUG: 6.0.2 - False Disk Overload Playing Loop in Context

SUMMARY:

To me, this seems like a SERIOUS bug.

When playing some loops in loop browser with “Align Beats to Project” selected, the loops will break up and/or fail to play. The disk cache indicator will flicker red. This appears to be something related to the warping algorithm.

This is an intermittent repro:

  1. Open an existing project… My project was 32bit 44.1kHz
  2. Open Loop Browser
  3. Turn on: Align Beats to Project, Wait for Project Play
  4. Select a loop… the loop I selected was 16bit 44.1kHz
  5. Set the cursor somewhere in the project
  6. Press Play

RESULT:

Project plays. Disk cache usage meter goes to 100% (red). The loop appears to play (the cursor in the loop browser moves) but there is no looped audio. The second time the loop plays, it plays about 50% and then starts to break up/distort and the disk meter goes to 100%.

NOTES:
Disk is healthy, 1TB WD Caviar Black. Far more complex projects play many, many channels of audio off this HDD with no errors.

Loop plays fine not in context of project when I turn both “align beats to project” and “wait for project play” off. So this appears to be some sort of warping algorithm problem.

Bump. Steinberg, please acknowledge/comment. I can provide test files, but since they are from retail loop libraries, I’m not at liberty to attach to this public forum.

Hello,

No problems here with your repro. Also no other reports came in.

Cheers,

Chris

Can I send you a particular WAV (acidized) that does this? Please contact me directly. I have found whole libraries that exhibit this problem. They’re from Sony, who invented the format.

Daren check that the mediabay has the correct tempo information for the loop, and that it isnt defaulting to 120bmp,as it commonly does with acidized files… also I would advise to enter the correct category for the type of loop, so that cubase uses the correct algorithm for time stretching. :smiley:

I could also suggest to completely wipe the Acid metadata from your acidized files,and re tag them within mediabay. as the “warp” marker metadata is regularly written incorrectly by Loop manufacturers… some use the “Acidizer” program for doing bulk conversions, and it makes mistakes!.

:smiley:

The loop was tagged correctly. I may just attach the file to this message and see if others repro. And attach a video.

Ok, I have two things to share. The first one is a video. Unfortunately, my screen capture product won’t capture the audio of my ProFire 2626, so you just have to keep your eye on the disk overload meter.

http://www.youtube.com/watch?v=n4MKsWNt4xc&feature=youtube_gdata (best watched in 1080p)

In this video you will see thaty I have the standard Steinberg “Empty” project loaded. I have opened the loop browser to a location on my content HDD that holds content from a new loop library I recently purchased from Sony. (They invented acidized WAV, so this should be a good file–every file on this loop library produces the same result, by the way.)

The first time I play the loop, I turn off “align beats to project” and it plays just fine. Note that the disk overload meter is completely empty.

The second time I play the loop through I turn on both align beats to project and play in project context and hit play on the transport. The default project is 120bpm, so this loop should play at 120bpm.

You see the disk overload light shoot to RED. What I’m hearing that you can’t is very broken up/distorted audio for the first loop and then silence after that.

That’s the bug.

Ok, I have also attached the exact WAV file I used to repro the bug. It is here:
Hammer Break 04.zip (426 KB)
This file is only for the purposes of illustrating the bug. Try it yourself. I reproed with stereo and mono WAV files from this library and one or two others.

This seems to me to be another elastique bug.

This problem dramatically affects my ability to audition loops for inclusion in projects and therefore is a major productivity issue. A workaround for now and acknowledgement of the issue and plan for future fix would be greatly appreciated.

Reported (28705)

Thanks!

Hey this is killing me… I know you’ve reported it, but is there a workaround for the bug? I would really like to be able to preview loops and so many of them don’t work. These are all acidized WAV files from Sony Creative Software (the maker of Acid, so I’m pretty sure they know how to create proper acidized WAV files :wink:)

hey there… I would like to purchase Ambient Metal Constructions, but I’m not sure that they’ll play in Cubase 6. Before I spend my money, is there anyone who can say whether or not ACIDized wav files, Apple loops would work well in Cubase 6, and could they be manipulated, ie. pitch, tempo?
Thanks
Enoque

Yes, Cubase can play and lock tempo with Acidized WAV files. What I reported above was a bug in previewing the loop in context for certain Acidized WAV files and I don’t recall if Steinberg fixed it.

Chris: maybe you can comment as to whether this is fixed? If we don’t hear back I could try that original file again and see if it works.

Since then, however, I’ve started to use FXPansion Geist for my loops because it takes a loop and automatically detects the individual components, breaks them up, and then creates a pattern in it’s pattern sequencer to play the loop back as it originally existed… however, then you can create many more patterns with the same loop material giving you the ability to remix your loops in a simple and elegant way.

It would be SUPER nice if Cubase 7 had a feature like this built right into Cubase that didn’t involve using a VSTi, but Geist is great so if you find yourself working with loops a lot, try it out. Check out FXPansion’s Youtube page for lots of examples of how Geist works.

Cubase, however, is just fine on its own (providing the bug I reported has been fixed or your lucky that your loops don’t exhibit this bug).

Darren, As far as I was aware, or detected no bug when playing back acidized wavs m8…any problems with acidized files not playimg back correctly can be a laid blame to the content creators not entering the proper slice & tempo matadata inside the wav, whicvh is what actually makes it acidized…MANY default to 120bpm, and then metadata is what Mediabay uses to play the loop in context…If incorrectly entered data, is displayed in Mediabay…this data overides Cubases calculation of using Lenght/Bars & beats to calculate the tempo of a loop.

Erroneous metadata is usually to blame when playback of a loop is incorrect in Cubase…and to the chap above, Cubase plays Aiffs fine…as all it is, is a wav, with a different file extension. :smiley:

Discoworx you didn’t read the thread. There’s a bug acknowledged and logged by Steinberg. I even provided a file that reproduced the bug above. It’s properly tagged.

NOTES:
Disk is healthy, 1TB WD Caviar Black. Far more complex projects play many, many channels of audio off this HDD with no errors.

I’m pretty much certain you’ve covered it but you never know. Does that disk need formatting?

No–when I originally logged the issue, the disk was brand new, but I also confirmed the disk is healthy and it’s also the disk where I stream all of my project audio without trouble. Also Steinberg was able to repro the problem and logged it with the attached sample. You can download it yourself and see if you have the same problem.