[Bug] Bounce affected by MIDI input while Exporting Audio

This is a long-standing issue still present in Cubase 6 and seems like a very big oversight.

File -> Export -> Audio Mixdown

If there is a MIDI track record-armed in your project when you bounce audio, any MIDI received (ie, from your MIDI keyboard controller) will be printed into the bounce! This should never happen. What makes it the most bizarre is that it happens regardless whether you select off-line bounce or real-time bounce. Even if you off-line bounce, it will receive MIDI on any armed tracks and pass it through.

Suggestion to Steinberg: Any MIDI-thru should be automatically disabled at time of bounce!

(Cubase 6 32-bit mode on OSX 10.6.6 - Mac Pro 8-core)

Hello,


Ok, this should not happen, but who playes on a keyboard during export ?

Workaround: get a cup of coffee during audio mixdown :wink:

Cheers,

Chris

I think it’s a pretty serious issue and really represents an oversight in programming. I’ve had notes and artefacts appear in bounce-outs and I am certain it’s attributable to this. It’s very easy to occur in my situation where my arms are resting on the MIDI keyboard as the computer keyboard is on top of it.

I found this as well, but now I just switch off MIDI input while rendering.

(just playing Devil’s Advocate again, for a moment :wink:
While I agree that MIDI Input should definitely be disabled during non-realtime export, there are occasions where it could be valuable during realtime export (I seem to half-remember once needing to manipulate a MIDI controller to an external device during a bounce… but don’t ask me now why I couldn’t have automated it first :wink: )

We will have a look (28140)

Please make this a preference! I know. weird… But I sometimes will nudge a fader during realtime export on rough mixes for a better reference track.

I agree that it should be a preference.

Especially the fact that it happens while off-line bouncing (faster than real-time) is a scary thing!

Thanks for your input, everyone.