bug: chord grace notes are not possible?


The piece I’m inputting into Dorico has a grace note that is a chord. Dorico will only allow inputting individual notes and transforms it into a sequence of notes. I’ll probably use a hack with voices, but this is a bug that should probably get fixed next version.


Do you have Chord Input engaged? It automatically disengages when you switch to Grace Note Input, and you might not have noticed it.

have you tried to do it? I am entering the chord using a keyboard by playing all 3 notes at once, in grace note mode.

Oh, I’m away from the studio so I’ve tried it with the computer keyboard, not MIDI input. I’ll try it later. In the meantime, even if there’s something wrong with the MIDI input, you can touch it up my going into Chord Input mode and inputting at the computer…

It indeed seems to be something wrong. But if you activate chord input (Q), and enter the notes one by one (from either midi or computer keyboard), you should get what you want. For some strange reason, activating chord input and playing a chord also gives a sequence.

Activating Chord (Q) and eighth Grace Note and playing the chord on a MIDI keyboard does give a grace-note chord.

But it isn’t unreasonable to expect grace notes to allow chord input from a midi stream, when you shouldn’t have to toggle Chord input. Let’s see if someone from the team chimes in.

The upcoming “add-intervals” capability may prove very helpful in this area.

Yes, this is a bit of a rough edge in the MIDI step input method at the moment, which we intend to fix. You shouldn’t have to engage chord mode to input a chord from a MIDI keyboard, but it does work as a slightly awkward special case for the time being.

Thanks, this does indeed solve the immediate problem. Much appreciated. I had done crazy creation of 3 voices and used engrave mode to pull the grace notes on top of one another.