BUG: DCOM connection to program 'Synsopos.exe' failed.

SInce the latest update, Cubase has beein doing this to me: Either upon loading a song which uses the onboard effects of the Steinberg UR 28m (my soundcard) or quitting the same, I get these:

Application ‘Sweet Spot Morphing Channel Strip VST 3’ has caused the following error:

DCOM connection to program ‘Synsopos.exe’ failed.
Error:The object invoked has disconnected from its clients.

Application ‘Media Service’ has caused the following error:

DCOM connection to program ‘Synsopos.exe’ failed.
Error:The object invoked has disconnected from its clients.

Application ‘FCP_SMT_193_HS_VST3_Presets_04.vstsound’ has caused the following error:

DCOM connection to program ‘Synsopos.exe’ failed.
Error:The object invoked has disconnected from its clients.

and many others. The program has to be terminated in the task manager.

Is my dongle failing? Synsopos has something to do with the dongle, doesn’t it?

Does not happen every time.

Win 10 64 bit latest update, Cubase Pro latest, latest drivers for UR28m card

This should be a bug. I went through the Internet searches for this -
Updated ELCC - still happened
Tried to disable DEP for synsopos.exe, but apparently, in the new world order, it must run with DEP enabled per Windows and apparently the synopsos requirements conveyed to Windows, so not possible to try
Moved my dongle off the hub it was on and plugged directly into my laptop - no difference
Ran ELCC maintenance - BS, doesn’t fix anything

The only thing that worked for me was to completely uninstall ELCC and reinstall. Keeping my fingers crossed but it has been a day now.

I wish they would acknowledge real bugs and fix real bugs. I’m quite sure this is someone else’s fault though. :laughing:

Seriously, just detect when this happens:

  1. Cubase senses something wrong while it’s open that wasn’t happening when it first started up
  2. Do whatever necessary to correct whatever corrupt thing is there that is causing this error that affects paying, valid users or your software

Is this explained simply enough? This bug sucks and has obviously been occurring for years. Fix it.

Thanks, and I agree. The bug is new to me, though. It also seems to be occurring pretty reliably (?) if I drag something from the Media Bay onto the Arrange page.

This is happening to me now. Any updates on this issue?

Im going to take some time today to document my experience with this as it doesnt look like this “bug” has been resolved. Will post here soon and post a question to the main forum relating to dongle/eLicenser updates as that didnt fix it for me.

It all began when I launched Cubase and got the error regarding Synsopos. Ive numbered my attachments and hopefully they will appear in order. Im glad I had the presence of mind to capture that first error or I would be going down even MORE of a rabbithole than I did.

The next error message to me that there was no license for Cubase. I looked at the licenses on the dongle and Cubase was missing (ONLY Cubase- other stuff was still there)/
When I logged in to My Steinberg, of course my license for Cubase was there, so I tried updating to the latest version All I would get was the error message shown below in attachment 2. “Soft e-licenser altered in an unrecoverable way.” Sweet!

I considered pushing the big red button on “Zero Down Time” which I did once before for an old dongle that had died, but I couldnt see why my dongle would be the issue since the other licenses are visible on there. In any case, all my efforts to fix this via the means suggested on Steinbergs site led to nothing ecept “no license found” when I launched Cubase. (fig 3)

Then I thought I should completely uninstall the elicenser program and reinstall. BUT FIRST, I remembered I had recenty installed Cubase on a laptop which was not updated with the newer version of eLicenser. I put the dongle in it, and launched Cubase just fine. That was eLicesner version

The reason Im focusing on the updates and version number is because my first thought when this happened was WHAT CHANGED??? There was a Windows update, which I suspected as the problem, that had occurred prior to my attempt to launch Cubase. But Windows doesnt update the eLC software automatically and to my knowledge eLC doesnt look for updates automatically. You have to update it manually each time.

The problem is: the update didnt fix the issue, but an older version of eLC DOES work with the dongle on the other computer. The dongle is not the problem. The license is valid and fine. Its the software that is the issue.

So always being told to update update update, and NO option to roll back to a previous version presumes newer is better. In this case, its not true.
Thankfully my IT husband said “surely you have an installer for a previous version on your computer somewhere”. DUH. So now I am left with two options.

  1. Completely unintall eLC from my work pc and reinstall the latest updated version hoping this will do some magic or
  2. Completely uninstall eLC from my work pc and reinstall the version of eLC that works on my laptop which is

For those who want to know the laptop is running Windows 10 Pro Version 10.0.16299 and the Work PC is running Windows 10 Pro version 10.0.17134

Not everyone has Cubase on two computers, but this would be an example of why it can be a very good idea if you can do it. I would be lost right now if I didnt have the laptop to test this. I submitted a ticket for help days ago and of course its going to be a wait.

Thoughts? Experiences? Suggestions?
_3 no license found.JPG

_1 Synsopos.png

It appears that UNINSTALLING the elicenser and then reinstalling the latest version (the same updated version that did NOT fix the problem when I simply updated to it) has fixed the problem.

It would seem reasonable to, from now on, try uninstalling the elC and reinstalling (and may as well be from a new download from Steinbergs site- why not) should be a first step if merely updating doesnt work. In the end, as far as the user is concerned, it doesnt matter WHY a clean install works when an update to the identical version doesn’t. The only reason I didnt try this at first was the ominous message “soft licenser altered in an unrecoverable way” and I wasnt sure if it was possible the dongle stored license for Cubase could actually be overwritten in some way. Apparently not, but again, I would not know this for sure had I not happened to have another computer with Cubase on it to verify the license WAS actually on the dongle and Cubase could start up.

I hope this saves someone some time. I’ve altered the subject to reflect this solution as an instance of a fix, of course not being sure that will always fix it in all instances of synsopos error messages. It would appear others tried updating alone to no avail, and probably figured out later to re-install eLC.