Bug: Drum Map for all moved tracks

Hello,
I discovered a bug in C Pro 8.5.15 that i can reproduce 100% of the time. Sometimes i noticed that different drumtracks in my project all of a sudden used the same drum map wich wasn’t my intention. Even Those drum tracks that i created the drum map directly from the instrument like Groove Agent 4 and SE 4. Also with BFD3 you can directly create a drum map from instrument.
i now discovered when different drum tracks with different drum maps suddenly have the same drum map applied. It happens when you have the drum editor opend and Copy several Midiparts across several different Midi/Instruments Tracks all Tracks you copied will now share the same drum map


Steps to reproduce:

  1. Open a blank projekt and insert 2 Instrument Tracks (this works with Midi tracks aswell)
  2. Insert an instance of Groove Agent SE4 or Groove Agent 4 in each of the tracks.
  3. load a patch but different once in each of your two instances of GA4.
  4. Create drum maps for both Instrument Tracks.
  5. Insert a blank Midipart in each of the Tracks
  6. Open the drum editor by clicking on one of the Midiparts.
  7. Leave the Drumeditor open and select both midiparts on your project window and copy them to a different location.

If the bug happens to you aswell now both tracks should use the same drum map

If a track contains a drum map and some events from other other tracks are moved together, all the other tracks will also set to a drum map.
Have not seen this before, so it must be a new bug introduced with the latest update 9.0.10

+1 (got the same issue)

Yes, this is a very frustrating and time consuming problem, especially when you have to switch 40 tracks back to the No Drum Map setting on a deadline. I’ve been having this problem since at least Cubase 8.

This Problem exists since Cubase 8!!!
And not a single person aknowledge it till now.

I allready showed this here
https://www.steinberg.net/forums/viewtopic.php?f=229&t=98212

This only happens to me if i have the drum editor open during copying several midi parts across several tracks.

I merged Novikthewise’s repro with this thread - it appears at the top due to the sorting being by date.

For me this is happening in as soon as I select a drum part and non-drum parts together: the tracks of the non-drum parts immediately get assigned the drum map (and consequently go silent because of the channel). Version 9.0.20.

Afaik the bug is here again after the update to 9.5.10 :open_mouth:

Please don’t forget to fix this bug (again)… it’s so horrible if editing midi events other events will after moving/copying set to a drum map.

Yes, please fix this, it’s a huge PIA.
Does anybody know a way to switch back all the tracks to no drum map in one move? I tried selecting them all and using channel link but no luck.

Oh yes… major workflow killer! Please fix it, Steinberg Crew!

I know it’s an old thread. But I occurred the same issue with Cubase 9.0.x.

I thought it was a bug but it’s a feature that you can enable or disable. Go to File - > Preferences - > Editors
Uncheck: Editor Content Follows Event Selection.

In my case that solved the issue, at least for Cubase 9.0.x

I hope this reply help someone.