[BUG] Fades On Very Short Clips Ignored On Mixdown

Have you had this problem yet?

I’m exporting 8 sound variations of a very short sound for a game. I made cycle markers for batch exporting. As you see my sounds are very short (green event is about 2 frames in a 30fps project = 0.066 seconds). In this image, 1 grid line is 1 frame. So the green events have a 1 frame fade in and 1 frame fade out.

When I do an audio mixdown of the cycle markers, the fades I made are not taken into account, they’re ignored. On other, longer sounds, fades work no problem, but here it doesn’t. Does this have something to do with the short fades or the short events? But why should that matter? See here an image of the export in RX. You see it’s full volume from start to finish. All you see are the 10ms auto fades I configured.

But when I select the green events and do a Render Selection Export / Render in Place, fades are rendered. See below. Especially in the lower frequencies you can see how the energy decreases from the middle on and then the whole thing fades out. It also sounds correct, while the sample before sounds cut off.

What am I doing wrong? Why is Audio Mixdown and RIP different? Any ideas?

I guess nobody has experienced this or never had to export sounds that are 2 frames long… :blush:

That is a limitation which is deliberately build in.
Such short clips can cause problems with buffering.
For example, when you would -by mistake or other- play a 2 frame sample in a loop, the machine would go ballistics with dramatic results. Don’t remember exactly what the shortest possible clip is, but I’m sure this is the problem you bump into.


Thanks Fredo. I’ll have to work around it somehow then.

But why is it only a problem with mixdown then? In the timeline it plays fine. Even if I have the 2 frame clip in a cycle region and play it in cycle mode :wink:
I also tried to make the cycle locator region bigger, it didn’t help. So it’s really the individual clip that needs to be longer in the mixdown?

Thanks again.

If you export the (large) cycle range, it should work.


Hmm it didn’t work for me when I tried it last time. I’ll try again to make sure.

Thanks Fredo, I can now confirm this is the case.

I exported an 2 - 9 frame cycle as sound. This caused fades to be ignored on mixdown.

The magic number seems to be 12 frames of a 30fps project. Cycle Markers of 12 frames and longer do take fades into account. That means your sound needs to have at least a length of 0.4s for the fades to work correctly.

I still wonder why they play nicely in the timeline, even though I enabled a transport cycle of that 9 frame region. I think a sound engine should be able to cope with whatever size a sound is, especially in offline mixdown :frowning: Now I have to keep an eye out for short sounds.

You could record your mix internally to another track and export those clips.

Yes, I could. It’s good to have a workaround. I just selected the clips and did a Render in Place.

But it’s annoying as hell if a mixdown doesn’t work and I have to resort to other methods to achieve the same outcome, just with more effort and it took longer (realizing there’s a problem, looking for a cause, googling, reading forum, writing post). Why can’t the mixdown just work? That would be my question. Or at least Nuendo spitting out some kind of warning. Again I, as user, am required to work around some some obscure, opaque stuff.

Sometimes it’s like Voodoo. It only works when it’s not full moon. And when you create a project exactly at midnight, then the project file is broken and has all sorts of weird malfunctions… Maybe I should start thinking about offering chicken blood.