BUG: grid changes to "seconds" when switching between Warp Grid to other tools


Steps to reproduce (as shown in the GIF)

  1. Set up view to “Bars+Beats” grid and “Bars+Beats” Linear
  2. Change to “Warp Grid” tool => it changes to “Time Linear” (as expected)
  3. Change back to select tool => grid changes to “seconds” for no apparent reason. Bug!

Since I’m switching between tempo editing and warp grid editing this thing has been driving me CRAZY. I think it’s been around for more than one version too.

Also - if anyone knows of a way to work around this - I’ll be very happy.

I couldn’t reproduce this issue and my time displays are set like this:

Primary Time Display: Bars+Beats
Secondary Time Display: Seconds

How are yours set?
Also, on what Cubase version do you experience this issue?

This are my setting at the beginning:

Not sure what you mean by “primary” and “secondary”?

I’m on version 12.0.20 right now, but I don’t know in which version did it last occur.

Primary Time Display and Secondary Time Display can be set on the Transport Bar.

Drag these three dots to the right (to reveal the Secondary Time Display):


It is seconds

After doing a little bit of digging, I’ve found this text (in the Release Notes of Cubase 12.0.30):

Switching from the Time Warp tool to other tools no longer changes the format of the timeline unexpectedly.

You are out of luck if you’re still using version 12.0.20. Unless you find a workaround…

1 Like