Bug in MIDI CC curve editing?

Ok Just found out you can double tap to select all the CC points and delete them so I take back that comment about “no clear all button”. Still I do think the midi CC could use work to be feel better, at least on par with the automation editor.

Hi @LSlowak! Hope all is well.
Just checking if you can provide any update on this fix or any work in progress?

Thank you!
Jon

I’ve noticed that as far as drawing the initial CC control curve, having the snap to grid option set to “off” seems to improve things. There may be the odd double point but in general it produces single points.

When trying to draw a curve with the snap option set to anything else I get multiple stacked points at each point in the curve. It’s as if Cubasis is receiving the curve information but snapping anything in between the grid to the nearest option, resulting in the stacked points.

Don’t know if that makes any sense?

+1 to the request for a function to thin out CC points in a curve.

1 Like

Yeah with the grid off you get tons of horizontal points, but no verticals, but the grid is useful when you want to make simpler shapes that follow the note steps… but anyway this stacking of points is clearly some type of bug, but do you hear it actually affect the sounds??? Is it just visual or does it affect the sound? It seems to me those stacked points get ignored and the only cc value that actually affects the sound is the one at the same height as the rectangle shape.

I need to make a better test with a very sensitive parameter (like delay time) or an auv3 with smooth visual feedback

1 Like

ok so I tried a quick test. I took animoog z, I binded midi cc 16 to the delay time (unsynced), raised feedback and mix on the delay really high, so even small switches of delay time would be easy to hear. At the start of the video you can see just the notes playing with the high feedback delay, no midi CC, then I paste the midi cc with the stacked points, but the rectangles make a flat line. It seems like the sound does not change, so the stacked points are ignored??? By the end I shifted the height on one of the point stacks so you can hear that even that slight difference in cc value produces a noticeable sound change.

However I had to delete the stacked points at the start and at the end of the MIDI event/loop, because those did cause the sound to switch and the point stacks were hard to position at the correct height, so I had to delete them and keep a single point (which is the time consuming annoying thing about this bug). Also I swear I could hear the delay time shift a few times while making the test as the midi looped over and over, so it might still affect the sound but inconsistently and scarcely. What has been your experience with this bug?

Hi @mcmillan.jon,

We hope to include the fix in an upcoming update.

Best,
Lars

Hi @LSlowak , just curious if a fix for this is coming soon?
Thank you!

Hi @ReflectiveHaze,

New updates will be announced once becoming available, Here, we also include the list of fixes etc.

Best,
Lars

:rofl: :rofl: :rofl: :rofl: :rofl: :rofl: :rofl: