Bug? Instrument Filter Overlay not showing when selected

In Write mode, I often switch from View to Galley, and find the Instrument Filter Overlay not showing. When I open the View menu, the item is, however, ticked. I have to untick it and then return to the View menu to select it again.

David

I’ve not seen this myself, but I can believe it may happen under specific circumstances. Can you pin down the precise sequence of events that leads to you switching to galley view and it not appearing as expected?

I have tried to investigate further, but not yet been successful. All I can say is that, having toggled the Overlay, I expected it to be permanently displayed. Thus I have been surprised on more than one occasion not to see it there when I switched to Galley. For instance, I just opened the program and the file opened in Galley View, with the Overlay sitting there as expected – the usual variant of Murphy’s Law. I will keep a careful watch out for helpful clues.
David

My Instrument Filter Overlay has gone missing too. In the Write menu it says it is on. Selecting/Deselecting doesn’t make any difference. Switching to page mode or any of the other modes doesn’t do anything either. All the functionality of the filter is available in the menu, it’s just the overlay that’s gone missing.

Yes. I have still not been able to discover what triggers this: it is missing almost every time I return to Gelley mode.

I have to hit the entry in the Write menu twice to turn it back on.

David

Even doing that isn’t working for me.

If you save, close and reopen the project with View > Instrument Filter Overlay activated, does it then appear?

Sorry! I just noticed a typo in my last message. Now corrected.

David

FWIW, closing and reopening Dorico causes the Instrument Filter panel to reappear. But doesnt prevent it going AWOL later. :sob:

No. However, on a new project it does display. I was doing so many things that I don’t remember what I did so I can’t replicate it.

One of our developers spotted a replicable problem with the overlay failing to reappear when switching back to galley view yesterday and fixed it, so with any luck that also accounts for the cases reported here, and this should therefore be resolved in the next update.

2 Likes

Daniel, many thanks to you and your developer colleague for persevering in the search for this elusive critter!

Fingers crossed. :smiley:
David

As a follow up, it happened to me again. Always with an xml import. This time I switched to page view, back to galley, edited, went to engrave mode, came back to galley mode and the filter overlay magically reappeared.

I dont think XML has anything to do with it. I have been working with a Dorico created file that suffers from the problem.

Another thing has also been happening:

Returning to the jump bar, the previous command is displayed but not highlighted in blue. It has to be dismissed and the shortcut retyped. This is a pain when it is “Filter all dynamics”!

David

I can confirm that I am also experiencing both things…The Filter Overlay disappears with a non xml file and I also find that the last jump bar command is often not highlighted.

I’m having the same issue with the jump bar. I do find if I type the least common word - in your example ‘dynamics’ - what I’m looking to do shows up in the list quicker than typing ‘filter.’

1 Like

I have discovered that a better work around is to use the down arrow to navigate to the command you want and then hit enter.