[Bug?] Logical Editor Presets display incorrectly - w/repro

I’m currently writing up some notes for classes, and note that this has been present since at least Cubase 5. It’s easy to reproduce, and in my opinion should be fixed. The problem is as follows:

Issue: When you load a preset from the Logical editor, all values are displayed as numeric ones, even when being displayed as note pitches (such as C3) would be appropriate, and when the logical editor would normally do so.

Repro:

  1. Create a MIDI track with some data.
  2. Open the Logical Editor.
  3. Recall the preset: Standard Set 1 > random notes (c3 - c5).
  4. Look at the values in the Action line - it reads:
    Value 1 Set Random Values Between 60 84
  5. Edit the values, by entering a note pitch in the correct format (such as D4). It gets mis-converted into a number (if you enter D4 then you get 4). You can only enter note values using the MIDI note number, not the note-and-octave format.
  6. Change the “Value 1” in the action target to something else, and then back to Value 1.
  7. Change the Operation back to “Set Random Values Between”
  8. The note pitch entry for Parameter 1 and Parameter 2 will now work as it should do - you can enter EITHER note-and-octave values (C3) or MIDI note numbers (60) and it will work.

Observed Behaviour: When a preset is recalled, Parameters which contain pitch-and-note values (such as MIDI notes) do not work correctly; they are displayed as numerical MIDI note values instead of note-and-octave, and will not allow entry of note-and-octave (e.g. C3).

Expected Behaviour: It is my opinion that the values should be displayed correctly when the presets are recalled, and that they should allow you to enter the values in the correct format (note-and-octave or number) regardless of whether they have been recalled from a preset or inserted manually. It makes trying to teach people really difficult as you need to re-set things to be in a position to enter values.

Can someone please confirm this? It’ll only take a few seconds, and it should be fixed, IMO.

Yes, I can confirm.

Thanks Vic

Just for the record, I have confirmed this on Windows 7x64 and x86, using Cubase 6.02, although I believe it has been present since at least Cubase 5, and did the same on XP.

I wonder if this is correct behavior due to Middle C being different note/ octave values on different kit.

No. C3 = Note 60 in the MIDI spec. This is a Cubase issue. Does it do the same on your system?

Come on guys! Everyone b1tches about Steinberg doing nothing to fix bugs, but when presented with a clear and simple repro of one that could be fixed, no-one seems to do anything if it’s not a feature they use! :angry: It’d take 30 seconds to check this and post if your system is the same.

(And if you don’t use the Logical editor, you’re missing out on a really powerful tool, BTW).

Bump! I have tested this out on a couple more systems (6.0.2, Win7 x64), and found the same.

Confirmed here as well

Hippo

Yes, confirmed.
It seems to be related to a display pref and the logical editor preset:–>
Preferences–> Event Display–> MIDI --> Note Name Style–> “MIDI and Value”
If you have this pref set you can get rid of the occurence.

  1. Open the preset “random notes (c3 - c5)”
  2. In the action section click on the operation “Set Random Values between” and choose “Set Random Values between” again.
  3. Now set parameter 1 to C3 and parameter 2 to C5
  4. Now save this as a preset by clicking on the + symbol above in the preset section and overwrite the preset.
  5. Now when you load the preset this minor issue will not occure.

I will report this issue.

Gr,
JHP

Reported (29163)

Thanks djaychela!
Gr,
JHP