BUG: Meta Normalizer not working if a track is solo-ed

BUG: Meta Normalizer not working if a track is solo-ed… it seems to only work on unmuted tracks?

Even when working with clips on the same track, I still find the meta normalizer confusing… I just want to use it to A/B a bunch of files at the same RMS.

I have created a montage with 5 “versions” of the same song. Each version is on a different track. They’re all lined up sample accurate, and by clicking the “solo” button on whichever track I want to hear, I can A/B between any of them to see which one I prefer.
What I want to do is:

  1. Make every clip the same RMS - so they sound the same volume.
  2. The loudest “peak” out of ALL tracks is exactly 0db (so everything is the same RMS, there is absolutely no clipping anywhere, and absolutely no processing anywhere (other than gain change).

I don’t want to limit anything… I don’t want to process anything… All I want to do is change clip gain so that #1 and #2 are met…

How do I do this?


There’s a factory preset called “All Clips Same Loudness But Below 0 Peak” but it only brings lufs up to the loudest clip, so the loudest clip probably won’t hit zero if everything is originally at conservative or low level.

I think PG was going to work on a different preset variation, but until then, you could run in 2 steps:

  1. In factory preset “Get Even”, change loudness to -5 LUFS and change Limit Digital Peaks to Ignore Peaks. Run the Preset.

  2. Then run the preset “All Clips Same Loudness But Below 0 Peak”.

The meta normalizer doesn’t seem to be working at all… I try running the presets, and absolutely nothing changes…

All clip pre gain and post gain remain at 0db.

Well in that case it sounds broke. It works ok here. None of the factory presets do anything?

Not in the new version of Wavelab… I used to use it in older versions, but it’s not something I use often. I tried quite a few months back - couldn’t get it working then, and it still doesn’t seem to work.

It actually DOES work fine if the clips are on the same track. If they’re on different tracks, it does absolutely nothing… I just updated the thread title to report the issue as a bug…

You don’t have “Only Selected Clips” selected do you?

It works ok across multiple tracks here as long as that’s not selected.

No, “only selected clips” is not checked… I just loaded the presets exactly as you had suggested, but when I click “apply”, nothing happens.

I’m on 9.5.15, the latest version I think, and on Windows 10. So I don’t know. It works here.

Hmm… I’ll try to do a video and post it here… Maybe there’s something I’m missing, but I don’t think so. I think it’s a bug or broken somehow.

I discovered the problem!!! YES!!!

It was caused by having one of the tracks “solo”-ed. As soon as I unsolo the track, the meta normalizer works as expected…

Never noticed it before, but I think it’s probably intentional. If you know it works that way, I think the factory presets work as expected depending on whether they do fixed results or relative results. It’s the same with the meta-normalizer back in Wavelab 8.0.4.

But like you, I didn’'t expect it.

Except “All Clips Same Loudness But Below 0 Peak”. That one still is not as it should be imo.

It goes way back. Even in Wavelab 6, muted tracks aren’t normalized.

Hi. Meta Normalizer is not showing up in the tabs of WLPro 9.5. How do I get the meta normalizer? I only have the Level Normalizer.

It should be here: