[bug] midi recordings get cropped

Record a midi event a couple of bars long.

Record a new midi event on top of the first one and let it continue beyound the first one. Cubase should merge the first event with a second, new one. But instead the new event gets cropped and the new notes dissapear from where the first event ends.

Here’s the scary part: if you put Cubase into record mode where the notes should have been, the notes reappear when recording over them! But as soon as the recording stops - the note vanish again! If you look closely, you can see the very tiny midi events are in fact created.

THis continues - it keeps the recordings somehow in the background but you’re unable to use them, because no event is created. Solution: don’t record over existing midi events???

Please investigate further.

Have you set the MIDI record mode to “Merge” instead of “Replace” or “New Parts” ?

Cheers,
Bernard

Thre is a prefrence that snaps Midi to nearest bar

In deed, that would be “Preferences–> Record–> Midi–> Snap Midi Parts to Bars”.

To make this reportable we need to clarify the related preferences settings and the record mode and then frame out a more precise repro if a problem persists.

Slightly off topic but regarding the appearance of MID Data in the Events:
I set my “Preferences–> Event Display–> MIDI–> Part Data Mode” to “Blocks”.
Also I have lowered my “note brightness” a bit in “Preferences–> Event Diaplay–> MIDI”.
This makes the MIDI Data in the events displayed bold and fat. Nice! :sunglasses:
Try it!

Gr,
JHP

Check this video out - it should speak for itself.

  1. As you can see, I record a midi part on a blank track (unfotunately you can’t see the notes created in the part due to my phone camera, but they’re there)

  2. I then (in merge mode) record a new part over the first I start playing towards the end of the first part. As you can see - the new part is created as expected. Until the recording stops. The new part vanishes.

  3. You can also see remains of a previous take suddenly emerging at the left side!

  4. as you can see - nor resizing or double clicking fixes the issue.

So it’s two things: midi parts not being merged. And old recorded midi notes suddenly re-emerging.

And it happens whether snap midi parts to bars are on or not.

http://www.youtube.com/watch?v=UCoiN-v7eBg

Confirmed!

In fact, the later data on the "new "part is contained in what you call that "“previous take”… if you drag the visible Part down to a new track, then expand the Part that is still on the original track, you will see the extra data.

So, I’d say that’s definitely a bug (when MIDI Record mode= “Merge”).

Workaround…
Change MIDI Record mode to “New Parts”, then glue them together afterwards.

I already could reproduce. I will get back in this thread soon with my findings.

There is another issue with the recording mode settings, the preference “Snap Midi Parts to Bars” turned off and that the recording is started in the middle of a bar and not at a straight measure count.

The repro would be something like this:
Record Mode: Merge MIDI
Midi Cycle Record Mode: Mix
Preferences–> “Snap Midi Parts to Bars” turned off

  1. Set cursor to measure 2.2
  2. Record some midi
  3. Stop
    Strange: Two events are created.

It might even be three related issues if you count the “2 events are created with one recording” issue.

  1. “Recording a longer event on top of a short event and missing midi”: I have a working repro, still investigating
    Workaround:
    Set Record Mode: “New Parts”
    Midi Cycle Record Mode: Mix

Manually glue the created parts together with the glue tool to merge them
or select the track and manually merge them with a macro:
Edit - Select All on Tracks
Transport - Locators to selection
MIDI - Merge MIDI in Loop (make sure to check erase destination and set the settings in the merge midi dialog as appropriate)

  1. “2 events are created with one recording”: I have a working repro
  2. “notes suddenly re-emerging”: Still investigating

I will need some more time to investigate andformulate the repros. The first issue deffenitly does not have anything to do with “snap midi parts to bars” indeed.

Gr,
JHP

I don’t understand. There is no new and old part - they are merged, with the result that anything beyond the right edge of the original part is gone.

Here’s another video showing the ghost notes suddenly being brought back from the deleted:)

Also: notice the extremely thin midi part at bar 19 - gotta be related somehow?

http://www.youtube.com/watch?v=8eAZ7tPuSDw

Thanks for the information, we will look into it. (28118)

Here, there is indeed an ‘old’ part… but it is very thin indeed (too thin to drag, in fact it looks almost like a single vertical line… I had to lengthen it via the Info Line.

:neutral_face:
I did not wan’t to leave this as empty statement. However, there is no need for further assessment.
Enough has been said and the issue will be investigated by specialists. This thread is directly linked to the report.

Thanks Lasso and Vic!
Gr,
JHP

Had this problem too. I could fix it by closing cubase 6 and rebooting it. Then I updated the program and that doesn’t work anymore.