BUG - Multiple Takes to Lanes --> Editor doesn't display correct wave form for what is playing

Cubase 10.5.12 Build 123 ( Windows 10 x64)

I recorded some guitar riffs to a new Audio Track, set to Cycle Record Mode, looping Takes over the top of a 32-bar drum track.

I opened the LANES function on the Audio Track where the guitar playing recorded.

I am using the Comp Tool to cut and arrange the different slices of the Takes.

I am playing back the audio on the different Lanes, using the Comp tool to select which Slice / Take to prioritize. I havethe Audio Editor, opened up down below.

The Issue: The Audio Editor is not updating to reflect the audio “in the Take” that is playing in the Track List. In other words, it incorrectly shows the cursor playing in the Editor in the wrong location in the audio… in my case it is just stuck on my Final Take (the 4th Take). The sound is coming out correctly from the cursor in the Track List.

If I go to play the first Take for example, the waveform (and cursor) in the Editor stays stuck on the 4th Take audio waveform.

I can scroll to the left and see the Event boundaries (for Take 1, for example), and all of the various Takes are there linearly, as expected. But, in the Editor, cursor is located on the Start of Take 4. When I hit play, I “hear” the 1st Take, which is correctly playing above – but the cursor and display in the Audio Editor jumps back to my 4th Take, the cursor scrolls as if to be playing the 4th take waveform. The Audio playing through the speakers is from the correct “active take” in the Lanes display (say Take 1).

In Summary, if I play any other Take, the Cursor in the Editor does not line up with the cursor in the main Track List, it pretends to play Take 4.

I do NOT have Independent Loop turned on.

It seems to be a Bug. The Audio under the Editor cursor is not what is coming out of the speakers.

The Audio from the “Track List cursor” is correct (and the speakers match the wave form above in the Track List).

Hope this makes sense. Sorry to be a bit redundant. Thanks for any help or ideas on this one! :slight_smile:

Steve (LackLogic)


To understand this, you need to understand some Cubase general principles.

  1. When you are recording to the lanes, one long WAV file is recorded. Cubase cut the file virtually to the lanes.

  2. The Sample Editor always shows the whole file (it doesn’t matter if the whole file comes from the recording to the lanes or if it was a common file and you are using just snipped of it). by using Event Start and Event End markers, you can see where does the current event starts and ends. But again, in the Sample Editor, the whole file is present.

So if you put these knowledge together, you can understand, what you can see in the Sample Editor. You see the whole file (all takes one after each other) and you can see the currently selected (not necessarily the active) part of the whole file.


Thanks for the response. I wish I could show you what I’m talking about (maybe screen share?). Please read my very redundant and descriptive (apologies for it) POST again, and tell me if you are still not understanding. If necessary, I will try to re-write it, if that is the case. I just know that it is definitely not working as expected, and I am speaking from experience.

Note that I have been using Cubase for 18 years. I am definitely aware of the principles you describe above. Crystal clear on how the Takes work, and how Cubase records one linear audio file in cycle record mode, despite the layering that occurs in the Lanes.

Also, worth a mention: I have now spent another day playing with this issue (my “Bug”, as I am referring to it), and the rabbit hole is even deeper on this one than I thought. When I hit the button for “Musical Mode” for this guitar audio recording, it sent the takes out to like bar 4000, 8000, 12000 (YES, way way out to the right in the track list). Each Take is spaced with a mile of dead silence between them. I didn’t even realize it until I was wondering my my track overview was super zoomed out. It was accomodating the miles of spacing between the Takes that occured when I hit “Musical Mode” (the ♪) button.

Also an interesting minor issue: I recorded the guitar while recording at a tempo set to 120 BPM. The Sample Editor says the resulting file is 120.44 BPM. I have not touched the tempo (BPM) on this file (so naturally it is still set to the default of 120 BPM). Why is my resulting audio recording showing a slightly different BPM? It seems to have decided this all by itself. I would expect that if I record at 120, the subsequent audio’s definition would also be 120… ?

There is a little bit more, but I have no idea where to begin to describe the behavior I am experiencing.

Update: I shut down the file. Reverted back to an older version of the file. Started over. Re-Recorded some guitar into a new audio track. Can’t seem to replicate the BUG now… the Comp tool still doesn’t cause the Sample Editor to udpate. But the Arrow (Selection) Tool does cause the Sample Editor to update. Interesting.

Note: Turning on the Musical Mode (for the new guitar audio recording) causes the Takes / Lanes to reset.


I cannot reproduce it here. The cursor is always at the currently selected event (take) boundaries here.

Could you maybe do a video screen recording and share it here, please?


This is off topic. Make a new thread, or follow in other thread, where this has been discussed already, please.