[BUG?] Nuendo 10.3 and Waves plugin fields

Apologies in advance if this has already been brought up - I was unable to find anything via search for it.

I’m on a Mac running Mojave 10.14.3 using Waves v10 VST 3.0.2 versions.

In nuendo 10.3 I am unable to double-click on Waves controls to hand key in numbers. When I double-click on Waves controls my mouse simply jumps to a new, seemingly random location on screen (sometimes activating a completely different field).

In nuendo 10.2 this was not the case - double-clicking Waves controls automatically activated the field tied to that control and allowed me to key in a specific value.

I went through a small list of other vendor plugins and was unable to reproduce the issue so far - they behaved as expected. (the Outlaw plugin in the below examples is just a random plugin showing the expected behavior in both 10.2 and 10.3)

Comparing 10.2 behavior with 10.3:

10.2 expected behavior: https://gfycat.com/beneficialdarkgannet vs

10.3 broken behavior: https://gfycat.com/obedientfortunateicelandicsheepdog

Any insight appreciated.

  • DE

Waves has a feature to “single click” to enter numbers on a control. Is this on or off on your plug ins?

You have to start Nuendo, and press something (Waves knows) to get their preferences loader, so you can
check if this is on or off, and also to rescan all Waves plug ins if need be.

Hmm, thanks for the reply, but not finding a way to see the preferences you’re talking about (in fact, I don’t recall ever seeing those Waves pref options inside Nuendo?).

What I did find re: those prefs is from the WaveSystem manual, and in it it mentions:

"4. Waves Preferences (Pro Tools only)
When launching Pro Tools, hold Shift to view the Waves plugin Preferences window. The following options are available:
•Do not use AudioSuite plugins
•Do not use RTAS plugins
•Re-scan all plugins
•HUI control surface support (low resolution)
•Enable single-click text entry…"

Despite that the ‘preference options window’ seems to be Pro Tools only, I tried trashing the Waves prefs and rescanning in Nuendo, to no avail.

Again, def appreciate the suggestion, but unless I’m missing something, that didnt solve it for me. (though the behavior in Nuendo may still be tied to that ‘pro tools’ only prefs/functionality)

Wondering if perhaps a Dev would weigh in? (again, seems like a bug to me - even single clicking a control causes the cursor to “jump” away from that control, making the option of hand-keying in values completely unusable)

Well that sucks. I am almost sure that could be causing this issue.

I have had, over the years, issues similar to this, with displaying the plug ins weird, to where the mouse pointer is in relation to reality.
Like it jumps around when you click on Waves plug ins. And this sort of display issue in a few different DAWs.

I would inform Waves, this is most likely their issue, not Steinberg.

Right now I have Waves Mercury 10, it seems to work ok with Nuendo 10.3, but I am on a Mac.Your signature does not state your system…

sorry about that, and thx for the feedback - I’m on a Mac running Mojave 10.14.3 using Waves Diamond bundle v10.0.01 (I also have a couple individual V9 and V11 versions).

With that said, I can’t actually reproduce this issue today - Waves plugin GUI interaction is working as it should in Nuendo 10.3. :+1:t4:
It’s weird because I did not specifically try to troubleshoot with a Waves reinstall/update, although I did very recently install the free Waves Tone Shaper via their License Center and (I don’t recall it but) perhaps I also updated all of my Waves plugins to a new iteration - which very likely supports/confirms your suggestion this was a Waves issue.

Anyway, this doesn’t seem to be an issue for me any longer? (I’m confused as to how exactly it got solved, but certainly glad for it!)

Not sure protocol - delete this thread, or leave it up for potential reference for someone else?

Glad it got sorted. Leave it up. You do mention havng updated Waves…so that might have been the solution.

Cheers.