Bug: Playback loses some drum kit pieces with one-bar repeats

Consider the measures in the attached picture. On playback, Measures 1 & 2 play correctly. But measures 3-5 sound only the kick and snare. The hi-hat is missing from the playback.

The errant behavior is true with both Halion and NotePerformer.

Can anybody else confirm this behavior?

I’ve just tried this in a project of mine, could not reproduce this behavior.

OK. Thanks. I will reduce the project down to the minimim size that produces the error and post it for others to try.

The uploaded project shows the behavior. It seems that all the kit pieces play under the repeats, EXCEPT for the hi-hat. Very strange.
Drum repeats.zip (565 KB)

Indeed really strange. Didn’t find a reason, but when I select the whole bar before the repeat and copy it to a second drum set, the hi-hat is missing!
no hi-hat.gif

Thanks. Very peculiar. I’m thinking there might be something about the voices, as drum kits are managed differently from everything else. But I’d think some of the other cymbals would also have trouble in that case.

It may be something weird like the hihat being the last instrument (internally) on the kit list.

As I was reducing my dorico file to include just the problem measures, there came a point when I deleted a bunch of measures starting form the end and the problem went away. Those measures included some slashes and other things, so I though there was some interaction with other objects. But I restored the broken file and started deleting from near the front of the file and the problem remained !?

I also notice the last measure refuses to display a final barline, as if there is something hanging over. But I can’t figure that one out either.

Anybody else have a clue what might be happening here?

It does look like there’s some strange problem with this file. For some reason the bar repeat objects don’t live on the overall stream for the drum kit stave, but instead on one of the kit component streams. Perhaps something got messed up as part of some import/merge/copy/paste operation or similar. I would suggest creating a new drum kit and copying the parts over to create one that is in a consistent state.

It might be sufficient to delete the bar repeat region, then create it again when viewing the kit using the five-line presentation type.

Thanks. I will try that. It isn’t a big problem as I already exported my final MP3 before I edited the drum part. But it seems there is something lurking here.

Just for the record, I created this file from a template I have used for similar projects. I never noticed a drum problem on the other projects, but this one could easily escape one’s attention. I did paste drum parts from another Dorico file where I have accumulated a variety of utility drum patterns.

I never edited the drums in this particular file except directly in the single staff as it sits.

The plot thickens just a little. Deleting and re-creating the one-bar repeat region didn’t fix it, regardless of which mode the percussion layout was in (5-line, grid, or single-line.)

But here’s a strange thing. With the repeat range set for mm3-5 in 5-line staff (as shown above), I can switch to Grid mode and the repeats still show mm3-5, and fail to play the hihat. See “grid.png”

However, when I switch the layout to single-line, the repeat range disappears for mm3-5, but now appears in m2. The playback still sounds as before – working correctly in m2, but playing everything except hihat in mm3-5. While still in single-line mode, I delete that one-bar repeat from m2. Now no repeat signs appear anywhere, but the playback is correct with the repeats playing correctly in mm3-5, including hihat – even though no repeat signs appear. If I switch back to 5-line staff, the repeats appear in mm3-5 and the playback is correct including hihat.

I then went back to the arrangement I had been working on before stripping the example down to only a few measures and one instrument. Switching the drumset to single-line mode, I found one measure about in the middle of the file that had one of these renegade repeat signs (and no other measures had it.) I deleted that repeat, switched back to 5-line mode and everything played as expected. This explains why the problem went away as I was deleting measures starting from the end. Obviously I deleted that incorrect measure at some point without knowing what was under the surface.

That doesn’t tell me how my file got into that state, but it does explain the state in more detail.


Well done for spotting it, Craig. There’s no doubt an assumption that there will only be one repeat bar region for a given percussion kit at any one time, and undefined behaviour can occur if that is violated.

It is entirely possible that I did create multiple repeat ranges over the same measures by accident. I would have deleted the duplicates, but the damage is only visible if one switches to 5-line mode.

I have now run into the same exact problem described in this thread–the hi-hat stops playing during bar repeats. I was able to cut down my large project to the attached file which exhibits the behavior.

All of the bar repeats in this file were entered while in 5-line staff mode. I would expect there might be issues if I had switched to single-line mode, added conflicting bar repeats, and then switched back to 5-line staff mode. But I think there’s a bug if it’s possible to get the bar repeats into an inconsistent/invalid state just from editing in 5-line staff mode.

In this test project, switching from 5-line staff mode to single instruments mode (exiting Layout Options) and then back to 5-line staff mode causes the bar repeat to magically play correctly again. In addition, deleting measure 1 also cause it to play correctly. However, in single-line mode, the bar repeat is not visible on any of the staves, and there is no spurious repeat or anything I can see in measure 1.

This is Dorico 2.2.20.1286, although I don’t see anything in the Dorico 3 version history which looks like it could be a bugfix for this.
Bar repeat playback issue.zip (504 KB)

Update: In my main project, switching to single instruments mode and back did NOT solve the problem. However, in the measure which corresponded to measure 1 in the test project, visible only in single instruments mode, there was a spurious single bar repeat just in the hi-hat (on top of existing music for the hi-hat in that measure). Deleting that did solve the problem.

I believe this may have been inserted by me selecting one or two notes from the hi-hat and pressing the keyboard shortcut I have mapped to “create bar repeat region”. Since this did not have any visible effect on the score at the time, I didn’t attempt to undo it and just kept working.

I’m not sure this is strictly a “bug”, as Dorico did do “a” reasonable thing in response to my commands–insert a bar repeat in just that instrument within the drum kit. But I think it is clearly not expected behavior for a command to have no visible effect and break playback later. I would suggest that the behavior be changed to, when working in 5-line staff mode, all bar repeat regions being inserted either are inserted into the master stream for the whole kit, or are not inserted at all.