Bug Report: Cubase hangs when connection to Performer is poor

Tried to record 4-channel drumset with Cubase 10.60 and VST Connect PRO All good until I tried to download the HD files. Because of poor connectivity, download started slow and failed after some time. We tried multiple recording sessions, every time I tried to download HD files from drummer (with poor internet connection), after some time the download failed and in return my Cubase VST Connect PRO “hangs”. This means, no matter where I click on the screen, the only response I get is a “sysem sound” that indicates, that I should answer some modal dialog or similar - but there is no such dialog. The only way to continue is to kill Cubase via Task manager and restart.

We (drummer and I) observed this multiple times and every time I tried to download HD files via poor internet connection. An error message would be more appropriate than a not-responding application that has to be killed.

It is very likely that said error message is actually casted and waiting for your confirmation. Unfortunately, depending on many factors such as Operating System (you didn’t mention any), if the plugin is “Always on top” etc, such message dialogs may be hidden behind other windows. Check Taskbar or Finder to see if such a message box is hidden.
If “Get HD Files” fails, we provide a secondary option: have the Performer find the project folder (documents, VSTConnectPerformer) with the Cubase project name and have him send it to you by whatever method you prefer. Then, while offline (not logged in), choose “Get local Files” and point to that folder.

I’m using Windows 10, and the problem is only if HiDPI is enabled (have a high-res monitor). Looks like the message box is positioned somewhere outside my screen when HiDPI is enabled. With HiDPI disabled, the message box was visible and I could confirm the network error.

And yes, the “Get Local Files” option worked fine.

ok, we’ll check, thanks for finding out. We are actually working on improving hiDpi, sorry for the inconvenience.

the problem should be fixed with version 4.0.44 which has been released now, check it out.