when selecting my maschine jam units and maschine studio the mackie control dont function in the correct manner

my solution was add a mackie device leave it unconnected the add another device creating mackie control 2 then adding first jam unit, then add another mackie control 3 adding 2nd jam unit , the maschine at this point is added to the first mackie control but the maschine studio has limited functions , if i add another mackie control 4 the maschine studio has full control , but this makes the jam unit not function properly

this behavour only happens with cubase , i tried with Reaper no issues also with Digital Performer no issues

at this point i have my jam units at 100% and the maschine studio at 50% in mackie control mode

update another BUG with device setup loaded up project this morning , one jam unit was dropped from the setup . i’ll try saving each time i shut down ,reconnected the unit all was fine

i also tried version 9 the units went back to the old issue , so no doubt cubase issue