Bug Report - Sample Editor display audio in the wrong place

I’ve just updated to the latest 10.0.15 and still I have this weird bug where on a couple of audio tracks, when I go into the Sample Editor window, the audio displayed in the wrong position.

I have attached a screenshot so you can see.

  • Other audio tracks are fine.
  • This buggy behavior seems to only happen on two audio files I’ve bounced before.
    When I bounce other tracks, the display is fine. When I bounce the two problematic tracks (re-bouncing), it doesn’t fix the problem.
  • When I go back to the previous track version, with all the edits and cuts, the display is correct.
    When I bounce that again (the version with the edits), it is all fine.

Perhaps it’s a certain compatibility issues with bounces done in a previous version of Cubase (I think I’ve done it first in 9.5)?..

Just a really really weird behavior.

Luckily I still have access to the pre-bounced edit versions

Well apparently it wasn’t just that bounced audio after all… :frowning:

Have a look at the attachment screenshot and you will see there’s just no correlation between the audio shown in the arrangement (correct. that’s also what I hear) to the one shown in the sample editor (wrong. as if the audio has shifted).

Anyone came across it?

Help?

Bump…

And again… I use the latest Cubase Pro 10.0.15

It’s ridiculous…

That’s very strange. I’ve never seen anything like that.

Initially I thought maybe it was related to some kind of Offset setting. But after playing around with it can’t come up with any settings that create the situation you have.

Is this only happening on one Project or are you seeing it on multiple Projects?

Does it happen for all the Audio in the Project or only specific bits?

Are the 2 views of the waveform misaligned for the entire project or do they start off in sync and drift apart over the length of the timeline?

If you solo listen to the audio in the Sample Editor do the sounds and the cursor position match?

What happens if you manually edit the Audio in the Sample Editor so it looks visually different - do you also see those changes on the Track’s waveform?

If you still have 9.5 (or even back to 8.0) installed, what happens if you open the Project there? Don’t change anything just see if the two waveforms match there.

This could just be a display/redraw problem - several seem to have cropped up in 10. But if it was I’d expect others to be reporting the issue.

FYI, around here we tend to be a bit conservative about calling something a “bug” until we figure out if it really is a bug. Turns out most (but certainly not all) of the things people call bugs really are things like misunderstanding how Cubase works, configuration problems, corrupted Preferences etc. :wink:

One more thought. Your pic shows the Sample Editor in the Lower Zone. Do you see the same issue if you open the Sample Editor in a stand alone Window? Expect it does, but gather every clue…

All good stuff from @raino

My tuppence worth - looks like maybe some funkiness with Hitpoint Detection.? Have you deliberately used it to warp the audio at some point (or in the past).? It might be picking this up from your earlier project and applying some kind of ‘snap’ when you open it in the Sample Editor…? (guessing…)
So, two things:-

  1. (Always) Turn off Automatic Hitpoint Detection on import, in the Preferences anyway
  2. Turn off Snap To Zero Crossing on the Toolbar before doing a bounce

By the way, Hitpoint Detection, ha.! Just do a quick forum search for plenty of threads of complaints about how this tool now performs in v10. Definite worsening from v9.x days

All of which may or may not have a bearing on what you’re currently seeing… :slight_smile:

Good luck.!

I have been facing the same issue as well, also created a new post because I couldn’t find this. (Attached picture) Anyone found a fix for this? Please help it’s very annoying. I turned off automatic hitpoint detection, still doesn’t do the track. I’ve had some issues with automatic hitpoint detection a few times in the past as well, so I have it turned off by default