[BUG] RX2 created in Recycle 2.12, Major issues Slice Player

I have no clue what is going on, but I noticed a very strange and disheartening issue yesterday with freshly created RX2 from Recycle 2.1.2 not working with the Slice Player of Halion 4 if imported from the Cubase Mediabay or the internal sample browser (CTRL + I). Any WAV file I chop and save as an RX2 from within Recycle will load with only 3-4 of the slices actually producing any sound, and those slices are not in sequence one after the other. It will only load 3-4 slices but it may be slice 1, 4, 6, 10 for instance. Playback like this is obviously a complete no go. It lists all slices in order in the mappings screen but anything after the first 3-4 keys produces no sound. If I play those 3-4 keys while browsing the entire loop from with Halion 4 I can see each hit being played at completely different places from within the loop then it should. Keys 1-4 or C3, C#3, D3, D#3 should play slice 1, 2, 3, 4 but it does not. I have tried many, many different files to see what could be the problem and each one does the same thing.

Here is where it gets strange. I have RX2 files on my hard drive which were already created from God knows where, download and purchased in the past etc and these all load fine. To make things even stranger, the RX2 made in Recycle 2.1.2 by me will drag and drop just fine into Halion 4 from a third party program such as UVI Workstation.


What the heck is going on here? Why do RX2 files not created in Recycle 2.1.2 work fine when files created in Recycle do not, better yet, why do these ‘problem files’ play back in the Cubase Mediabay just fine and import FROM a third party plugin like UVI workstation via drag and drop without issue?

Something is up with RX2 files created from within Recycle that are imported from the Medibay of Cubase or the internal browser (CTRL + I) of Halion 4 itself. No rhyme or reason to this and very strange the say the least. I am extremely glad I have a workaround, but things shouldn’t be this way and I think there is an underlying issue with how Halion 4 reads and maps RX2 files when created from within Recycle and imported from Cubase Mediabay or internal sample browser.

I have gone over things so many times, disable and enable the stretch option, make sure no processing is done from within Recycle etc and it makes no difference. If I am missing something, please do fill me in. I have no problems submitting these ‘problematic’ RX2 files for further analysis if that would be deemed necessary.

Thanks for reading. I hope to hear something back as no thread I have created on this forum has had any official input from Steinberg themselves.

I tried dragging the files from Windows Explorer into Halion 4 and same thing as mentioned above. Files play and load fine Recycle and Cubase itself however.

Absolutely nothing on this at all? The problem didn’t just go away by itself. Though there is the workaround by using UVI Workstation to import into Halion 4, it isn’t a fail safe way. Upon loading the project it of course asks for the samples location cause it was imported from a ‘foreign’ place that is no longer actively holding the sample.


This issue is still present in the 4.5 beta release of Halion 4. Importing RX2 created from Recycle from the newly introduced browser menu exhibits the same faulty behaviour as when imported from Cubase Mediabay or Windows Explorer. Importing from UVI Workstation continues to work.

Steinberg? Anyone?

Alright so I figured out the problem on my own no thanks to Steinberg. In case anyone else comes across the issue I did, the problem arises if you try and load an RX2 from the same directory a WAV file is located with the same name as the RX2. Since Halion 4 apparently needs to extract a WAV from the RX2 before it can be used (as per the manual), it obviously conflicts with the WAV file already located in the directory.

I was editing loops in Recycle and saving the RX2 into the same directory from which the original WAV was located and then tried loading the RX2 into Halion when I ran into the problems. Moving the RX2 into a fresh directory which did not contain the original WAV from which the RX2 was created from solved the issue.

Do not save your RX2 into the same directory as the original WAV or you will run into issues.

Only took 1.5 months to figure this out for myself, too bad I didn’t have any guidance. If Steinberg knows how Halion 4 works when dealing with RX2 files, they should have known of this conflict and should have made it known to help me avoid all the headaches and hassles. I hope this can be of help to someone in the future and help them avoid what I had to go through. :imp:

This was rectified in the new Halion 4.5.2 update. All imported RX2 files now have _halimported added to the end of the extracted WAV file so as to not conflict with the WAV file already present on your hard drive which may have had the same name as Halion was trying to create when loading the RX2 file. This is a real big change and makes working with RX2 MUCH better now.