Bug: Snap turns on when loading workspace

Having the ability to save different workspaces is very useful. The problem is that recalling any workspace turns on snapping, something I hardly use, and when I use, I turn on myself.

But I do make constant use of workspace profiles because unfortunately I have two Samsung monitors, which as some of you may know, have the same EDID serial number, so macOS has trouble differentiating them. So when I load Cubase, everything is in the same monitor. I have to recall one of the workspaces each time to send the mixer window to the second monitor.

But that turns on snapping. Even if I turn it off and choose update workspace, when I recall it, it’s still turned on.

Sometimes I need to give the markers names, so I have a workspace that puts the markers window on the right of the screen and the project window taking up the rest of the space (BTW, is there no way to just double click on the marker and enter the name there like you can with Logic Pro X?).

When I recall that workspace, snap also turns on. So I turn it off. When I’m done working with markers, I recall the regular workspace and once again, snap is turned on again.

So it’s something that shouldn’t happen. Snapping should be something that is left to the user’s will, not turned on or off according to what workspace you load.

1 Like

Why not simply report the bug in a simple way so it can be simply reproduced without the reader having to parse a verbose and multi-topic narrative?

Also, please. Use tags. I will do it for you this time, by adding the Issues tag.

Here is your bug report:

Snap turns on when loading workspace:

  1. in any project, deactivate Snap
  2. save a workspace
  3. create a new workspace, also with Snap deactivated
  4. recall each of the workspaces.

Observe that Snap is activated upon recalling the workspaces.

1 Like

Sorry, so bugs are reported here in the forum, by adding the “Issues” tag? I tried to find a place in the support page that says “Bug Report” or similar but I found nothing.

But this is a bug, right? Or is there any way to turn this off in preferences so that it doesn’t automatically turn on not only when you switch workspaces, but apparently all the time for no reason. I keep turning it off and shortly after I see weird behaviors, like trying to draw CC1 automation and the pointer sticking to the grid, so I look and it’s on, but I never turned it on. Not even by accident. The shortcut is J, I use it all the time when snapping turns on by itself.

Or I click on the icon to turn it off. Either way, it keeps coming back like an annoying person you want out of your life and doesn’t get the message.

The point of my post is your report can only be useful if the problem can be reproduced by others. If you want to know whether this works as designed or is broken you should write to Steinberg Support. This is mainly a forum for user-to-user interaction, with some Steinberg people, as you must know since you’re so active here.

If you want to report a bug to Steinberg, and get an answer as far as whether this is a bug or if it works as specified, you should use your Steinberg Account, and open a support ticket.

1 Like