BUG VCA channels changing volume when switching on tempo track

Hi
I’m having a problem with VCA channels: When I switch on/off the tempo track or when I do changes to the tempo, channels assigned to a VCA track change their volume.

Repro:

  1. Create new project
  2. Create some audio/instrument tracks, put audio/midi data on the tracks
  3. Assign the tracks to an VCA fader
  4. Write automation with the VCA fader
  5. Switch on the tempo track

=> The tracks assigned to the VCA fader jump to max volume.

I did a short video which documents the problem: https://youtu.be/T8z1JFRx3pY

Sorry, but I can not replicate that behaviour here. It is working as expected.

I’m on PC. Maybe it’s a Mac thing.

Also can’t reproduce on Nuendo 7.1.30 / Win7 x64

Strange, I can reproduce the issue consistently in Nuendo 7.1 and 8. Any other Mac users?

Do I need audio and / or midi on one of those tracks? Or both?

Can you be more specific on step 2?

I tested it with audio tracks + a VST instrument (for the midi). I don’t think it is possible to put a plain midi track into a VCA group (I couldn’t at least).

Sorry I wasn’t specific enough.

It doesn’t matter what kind of tracks, I tried with just an Instrument track. I attached my test project with an Halion SE track, maybe you can try with that project?
If I write VCA-Automation in this project, then position the playhead in the area where automation data is written and then turn on the tempo track, the automated track’s volume jumps in strange ways. I just realized that depending on what level the fader is when you turn on/off the tempo track, it moves to max volume or unity. And sometimes it decreases volume in small steps each time I turn on/off the tempo track - see the video here for that behaviour.


VCA-Bug.zip (1.16 MB)

Can you please answer what I asked about earlier:

Do I need audio and / or midi on one of those tracks?

Sorry for not being clear enough: As you can see in the video, I did my test with random midi data on the instrument track. I haven’t checked if it also occurs with just an empty track. I also tried with audio tracks with audio events on it. However, the problem seems to be independent from the kind of track as it happens with instrument and audio tracks.

Bug confirmed - good catch. Activating the tempo track in the middle of some VCA automation does indeed offset the slave channels relative to the VCA.

  • Create an audio/instrument track, VCA track, and tempo track
  • Assign track to VCA fader
  • Move VCA fader
    –> VCA master and slave channel move in sync
  • Write automation on VCA master
  • Play back automation
    –> VCA master and slave channel move in sync
  • Navigate to a position in the automation written
  • Enable tempo track
    –> VCA master and slave channels are now out of sync

Ah, I did not know about activating the tempo track while the cursor is in the automation data area.

Thanks for reproducing the bug. Yes, it seems important that the playhead is in the middle of some VCA automation. I also have the problem that moving tempo markers in the tempo track destroys the sync between VCA master and slaves. I didn’t have the time to reproduce it consitently, will try later.

Which version is this?

Also, when you write “audio/instrument track”, what does that mean? Is it sufficient to use just an audio track or does ‘an instrument’ have to be involved somehow?

An audio or an instrument track. It’s pretty easy to reproduce in the public release of N8.

The bug concerning VCA channels and their slave channels getting out of sync when turning on the tempo track is not fixed in Nuendo 8.1.0