Bypassed effects affecting tone regardless?

Cubase 11 on Windows 10… I just noticed that inserted effects which are bypassed significantly affect tone which doesn’t make sense to me. I noticed with a bypassed instance of reverance where I couldn’t hear reverb but there was a weird chorus-like tone. I had to remove the insert all together. So I tested with a bypassed compressor I had on several tracks, HUGE difference in tone color (not compression)! What’s up with that? Isn’t the whole point of bypassing effects to not have them affect the track?

I’ve noticed this as well. What really turns them off is holding down Alt and then click on the “power” button on each insert. When it’s greyed out, it’s really off. When it’s just a bypass with a yellow colored button, I can still hear issues.

I’m on windows, not sure what the mac command is.

@Teo that’s exactly it thank you very much it solved the issue. In my opinion the bypass option is completely useless (other than in the case where you would want to use automation throughout the track, if that’s even possible?). Seeing as it colors the tone though, sometimes drastically depending on the effect, I would say it’s a very poorly designed feature. @Nico5 I use it on audio track inserts. Guitar specifically where tone can be quite obvious

It’s more likely that there is a signal from the sound card being monitored. So the input from the sound card and the signal from Cubase/plugin are playing at the same time. The signal going through the plugin is delayed by the latency, the signal from the sound card is not. Result is a phasing sound. Bypassing a plugin does retain its latency (as it should), turning it off will eliminate that plugin latency. The fix should be as easy as pulling down a fader in the audio device control mixer. (Not in Cubase)

1 Like

@peakae the card is a MOTU M2 and I don’t see any audio device control mixer for it. It does have control panel type software but the only options are sample rate and buffer size. No mixer options there. It does sounds like phasing though. Perhaps you’re on to something.

@Nico5 I just reproduced the issue from scratch, here is the scenario in list format as this forum doesn’t allow me to insert images. Perhaps because I’m a new user, kinda stupid but whatever.

  • 3 guitar tracks, all 3 with monitoring activated. Pan left, right, center.

  • Add distortion on the tracks. I use neuraldsp “Archetype: Gojira”. I assume any distortion will do.

  • Add impulse responses on all 3 tracks. I use ML Soundlab “Mikko” IR generator

  • Add Reverence on the tracks, the preset there doesn’t really matter. I used “Plate Twoforty6 small recital”. Add them last in the chain.

  • bypass Reverence and all 3 tracks

  • Voila, phasing/chorus effect

  • I bet you just need reverence on 1 track for the issue to occur.

  • Fun fact: every bypassed effect colors the tone. Reverence is an extreme example which significantly colors the tone as it give s a chorus-like effect which for example the Compressor doesn’t. The compressor just sort of muffles the tone a bit. Makes it less clear or “up front” if that makes sense. Once I turn off all bypassed effects, wow is the guitar tone ever louder, clearer, and more defined.

  • Verdict: bypass is not a true bypass and is pretty much useless. Perhaps my setup is causing an abnormal issue but if so it should already be documented by Steinberg as my only option is to not use the bypass feature at all. It’s essentially junk for me (and others)

no it’s not

how do you add this?
Impulse responses add high delay to the signal chain.

Yes it is in the context of my full explanation around my personal opinion applicable to me. It makes my guitar tone sound like something out of the 80’s and therefore it’s useless for me

@Nico5 I appreciate the tests! Do note that I don’t hear the issue on playback. I only hear it while monitoring live. It must have something to do with latency as steinberg itself says that bypass does keep the effect running in the background.

Bottom line is that my setup is using all default out of the box settings and I’m far from being a Cubase expert so all I know is that I plug in my guitar, I don’t touch any of the default settings, and I get significant tone issues while monitoring.

Most importantly, @Teo confirmed that this issue is happening to him/her which means that this is not an isolated issue. It does exist and I hope Steinberg addresses it at some point. Work around for now is to turn off the effect and not use the bypass feature at all.

Cheers for now and thanks for the responses everyone

Can you hear your guitar when the track isn’t record/monitor enabled? If so that’s your issue - as @peakae has touched on previously. In this instance you’re hearing your dry ‘live’ guitar input AND the processed audio in Cubase at the same time when recording.

In use, your guitar would either sound louder/fuller or slightly out of phase and a bit nasty when playing live vs playback (Due to the incoming signal being heard). - The effect would depend on latency (i.e. the offset of the processed guitar vs the dry incoming sound).

You just need to disable your guitar input from being hardware monitored to your speakers/headphones via the audio interface settings. That way you ONLY hear your guitar when it’s assigned track is record/monitor enabled in Cubase.

With a MOTU you do this via the Cuemix software i believe, just bring the fader down for your guitar input in the software.

Otherwise - This would be a major issue if it existed, surely? I bypass plugins quite regularly as part of automation and i can’t recall this being an issue. However, that’s on playback.

Sorry, that’s a newer MOTU unit, on the front of the interface are ‘MON’ buttons, these look like your hardware monitoring options - turn them off for your guitar input.

You also have an input monitor mix knob in the middle of the audio interface, i guess outputs 3+4 may be headphones? If so, and you’re using headphones you may need to turn this to be all the way across to ‘playback’ mode.

The result you want is that you can only hear your guitar signal when the track in Cubase is record/monitor enabled.

thanks @skijumptoes but I’m definitely not monitoring the dry live signal. I only hear the guitar when the track has monitoring enabled. I’m going guitar >> cable >> interface >> cubase and once there I use amp sims. I’m not using real amp/cab/mic.

That said, I do believe there’s something going on with latency and monitoring. Someone on facebook suggested it could have something to do with ADC being enabled but I don’t know where to find that in Cubase if it is indeed a check box somewhere. I any event, if there’s an easy “click here, do this” answer it’ll be great but again since it’s not happening on playback it’s simple enough to just not use bypass when recording and only use it for mixing/automation purposes.

It’s just crazy that you only hear this oddity when playing live - i’m gonna check later and see if the bypass option does affect live monitored tracks or not. I just can’t believe it wouldn’t be a major issue reported on here if there was a bug of that magnitude.

Is there much of a delay between when you pluck a string and hear the sound in Cubase?
Do you have the ASIO driver selected in the VST Audio System settings (In Studio Setup)? - if so, what kind of input and output latency is showing there?

By the way, ADC usually means analog to digital conversion/converter - there won’t be any setting for that in Cubase, as it’s just built in to your interface. Not sure what people are mentioning that for(?).

Just for clarication, the 3 guitar tracks which you referenced above - are they all being monitored live at the same time, or are they 3 different guitar takes?

If they are the same audio performance then yes, when you disable plugins they will phase as you’re overlaying the same audio file but Cubase will be applying a slight delay compensation based on the plugins you have instantiated - it has to do this as if you enable the plugin again you would hear the tail of the reverb - as it’s always processing in the background.

Turning it ‘off’ as per @Teo suggesting will completely take it out of the delay compensation offset.

I don’t know if you’re aware but if a track has 10ms of latency (Due to plugins placed in the inserts) then Cubase will play that track 10ms earlier than others so that once the processing has completely it’s in sync.

This is the reason different plugins produce a different kind of phasing, as their latency differs.

In regards to playing live, Cubase cannot compensate for additional latency on a live signal - so the effect could worsen.

TL;DR: It’s important to ascertain if the 3 guitar tracks which you pan Left, Right and Center are separate guitar performances (takes), if they are not - then this is generally a bad practise and you increase the risk of phasing issues - recording each track as it’s own performance will yield a far better end result if you want a wider sound.

thanks @skijumptoes I’m not the only one confirming the issue so I have to say it does affect live monitored tracks. Under what circumstances is the question.

To your questions:

  • There is no audible delay when I pluck a string
  • Input latency = 11ms and Output = 15ms
  • Sample rate 96000 buffer size 1024. Anything less than that produces clicks and pops on my 5 year old PC

For the 3 tracks.

  • I monitor all 3 simultaneously. I blend 3 different amp settings (different guitar sound on each track) and want to hear the full blend so I monitor all 3 tracks.
  • I am monitoring the live direct signal, not a recorded performance. The issue only occurs on the live direct signal. The issue is not present upon playback. But to answer the question, on playback, each track does have a unique performance but again that’s a moot point as the issue does not occur on playback.

Here’s the bare minimum setup to replicate the issue. I removed all possible effects for the sake of testing. It’s actually quite simple to replicate

Track 1

  • Panning is irrelevant. Generates same results. Left, right center, doesn’t matter.
  • nothing inserted. No effects whatsoever
  • monitoring enabled

Track 2

  • Again panning is irrelevant
  • Reverence inserted only, with a simple “plate” reverb selected. No other effects whatsoever. No amp sims, IR loaders, nothing.
  • monitoring enabled

The above setup colors the tone significantly. Change from reverence to any other effect, and it will also color the tone. Reverence is the one I’ve found to be the most audibly significant example of tone coloring.

Monitoring only track 2 = no tone coloring. It only happens when monitoring more than 1 track.

I also just tried switching out the MOTU M2 with my old Roland duo-capture, and the issue is present on both sound cards. So it’s not the sound card. If we rule out the sound card, it absolutely has to be something within Cubase.

this indicates a wrong setting with ASIO direct monitoring or a double routing inside Cubase
you hear the signal twice with a small delay that leads to interferences
one direct from the interface input and one signal send from inside Cubase
turn direct monitoring off or check your routing settings

1 Like

@st10ss @Nico5 and all I appreciate the effort in helping figure things out.

I can 200% confirm I am not using direct monitoring, the box in Cubase is not checked and the button on my interface is not activated.

For routing, I am using Mono In 1 to Stereo out. You are absolutely correct though as it relates to hearing 2 signals, I am monitoring both tracks simultaneously as I want to hear the blend of both tracks together. Both tracks do use the same live guitar signal but it is not a recorded signal.

To recap.

  • If track 1 has no effect and track 2 has the effect bypassed, then phasing occurs as I’m monitoring both tracks at the same time and only 1 track has the effect running in the background (bypassed).
  • If I put the effect on both tracks and bypass them both, then no phasing as it’s an exact match.

again… this is exactly the way it should work… the bypass should not trigger the latency compensation to recalculate
this is different for the on/off switch which will completely disable the insert

if you record something a high latency prevents exact playing therefore the latency compensation is switched off for plugins with high latency
nearly all IR plugins have high latency

I wouldn’t say that phasing is ever the desired behaviour but I can wrap my mind around the fact that it might just be how it works. Since bypassed effects still run in the background, they are still being processed and therefore the inherent latency is not bypassed. With that in mind, the bypass feature is not a true bypass. It’s simply a “remove effect, but process the effect” button.

In my opinion, the bypass should be engineered to stop processing and truly bypass the effect from the signal chain. But I can now see how that might not be technically possible. For instance, when I click an effect on/off I can hear a solid second of sound freezing as the software processes the command. That’s probably why they need to keep it running in the background as you couldn’t use automation if the software freezes every time you flick it on/off. @Teo 's work around is perfectly fine and a very specific thank you on that one.

Anywho, I’m amazed at those of you who kept hammering at the issue with me. Thank you

Ok, so If you solo each one of those tracks and then bypass the plugins, you will see the bypassing is having no effect on the actual sound. So doing that alone should prove that bypassing a plugin is not processing the tone in anyway.

However, the fact that the plugin exists, but the output is bypassed, Cubase WILL still apply latency compensation based on the plugins reported latency - Cubase does this as it needs to be prepared if you un-bypass it. i.e. if one reverb is causing 0.5ms latency - that track will be played 0.5ms before the others.

So, by bypassing the effects, all you are doing is increasing the chances of phase issues as you’re just applying a slight offset to each tracks audio arriving out of the master bus.

Presuming you understand the concept of what causes phasing of course.

If you don’t, just imagine cones on a speaker pushing and pulling to generate noise… If you overlap two of the same audio streams that have a waveform which cycles up and down (i.e. the push/pull), then when offset, one waveform will be telling the speaker to push when the other is telling it to pull - hence the phase result.

i.e. If you offset one of the audio tracks with no plugins added by the latency of your plugin that you’re disable, you would hear a simlar effect. i.e.:

I’ve just copied in two loops from the media bay as an example and offset one by 0.5ms (Which is what a 0.5ms latency plugin would add were it to be bypassed). It’s easy to demonstrate.

When you playback the audio, Cubase can offset the pre-recorded tracks by the reported latency so you don’t hear the issue - however, when live monitoring it’s unable to offset what you’re playing because you’ve not played it yet - hence why you hear the phasing when live monitoring a bypassed plugin which adds latency.

Does that make sense?

Technically, the first answer you got is the solution to the problem you face in this instance due to it completely disabling the plugin and thus removing it from the latency chain - we’re kinda getting dragged into semantics of ‘why’, but if it’s of interest to you - i hope you can understand.

I come from using Logic Pro, and being able to bypass or actually turn plugins on or off was actually a blessing when using Cubase. So it’s worth understanding the differences, and this case you’re supplying is a perfect example.

By the way, you can display the latency for each track on the mixer console:-
https://steinberg.help/cubase_pro/v10/en/cubase_nuendo/topics/mixconsole/mixconsole_channel_latencies_r.html

i.e. two multiband compressors (highly latent plugin!), one bypassed, the other disabled (un-activated), and you can see the bypassed version is adding 113.4ms latency still:-
image

If i was monitoring live through that channel it would be adding latency AFTER my signal had came in, say from the point of plucking a guitar string i wouldn’t hear the audio until 113.4ms later (i.e. So basically all that’s happening is an offet of +113.4ms is being applied).

Whereas on playback, Cubase would start the rack 113.4ms ahead of the other, and no delay would be heard vs the other track. It can do this at playback because it’s pre-recorded audio. Impossible for live recording though - hence why the offset caused is causing your phase issues.

just goes to show that there are no stupid questions. Thanks again folks for the additional interesting tidbits. I knew some plugins had higher latency than others (R.E. I’m looking at you, multiband compressor) but I didn’t know you could actually look up specific latency on a per plugin basis. Cubase is a jungle of features. Also key take away is the piece about Cubase offsetting tracks based on reported latency. That really shines a light on the whole thing.

Cheers

While I appreciate understanding the why and how, I still think the bypass feature is useless in the context of my situation. Notice that I marked @Teo 's answer as the correct answer as the only solution is to switch off the effect completely. Respectfully, I don’t think any of my statements were false as in the end, the bypass is indeed not a true bypass. It’s more accurate to say it reduces the wet signal to zero while keeping the effect module fully active. There’s logic behind why Cubase does what it does but a bypass bypasses the effect module. This does not. But again I appreciate you taking the time to explain the why and how.

These statements where wrong. The bypass build in to plugins work the same way as the one in Cubase. A true bypass is bypassing the signal chain not disable it. That’s why it’s called bypass.