C12 and Novation Automap

Anyone use Automap? Have you got it to work with C12? There is no script for my controller. Novation Impulse 61. I tried to setup my controller using the new Midi Mapper but it’s not allowing me to add more than 8 faders/buttons. Automap is not showing up in Studio setup under Devices. Why didn’t Steinberg include more scripts?

Same here!. I don’t want to buy a launchkey…Cubase , steinberg , yamaha, novation… WE need more scripts… I upgraded so i could page faders and cant… I set up my impluse 61… Rebooted and I had to set it up AGAIN…

Hi qbury,

am trying to get Automap to run a SL25Mk2 with Nuendo. Succeeded so far, but not through yet. Not perfect, but so far running OK.

The guide that came with the Automap software explains it quite OK. In essence, this is …

The use of the Automap device is not the correct approach for Cubase from the list of available devices. Instead, you just have to (just) ensure, that the Midi-Device for the the Novation Controller itself is active as. Input and output. Within Cubase, check Midi-Devices for it.

On top goes, that you have to enable each plugin (VSTI or FX) you want within the Automap Setup. It puts a wrapper around the original plugin. This is being re-scanned by Cubase/Nuendo once you start it.

Then just instantiate such wrapped plugin as VSTi or FX in an instrument track. Once you select the track with the mouse, the mappings wil become visible on the Novation controller. This is dependent on the buttons “INstrument” or “FX” on the controller (… the SL25Mk2 in my case). May be different for other controllers or keyboards.

On the other side … I would also be interested on what the Automap device within Cubase/nuendo is good for.

LG, Juergi

This is interesting, in that I still hold out hope that I can utilize my Novation Nocturn. A nice little controller that I would like to use in Cubase 12 :sunglasses:

I was never able to get automap working in C12. After uninstalling automap I was able to use Mackie HUI or the midi mapping in C12. I still wish I could use automap though.

Hey guys! I have automap working for what concerns controlling transport and cubase’s mixer. MIDI messages for CCs or Notes still don’t work, don’t know why, but I used the same .dll I’ve been using for Cubase 11 and previous versions, and that’s the one the should be placed in Program Files\Steinberg\Cubase 12\Components.

If you need it, it’s uploaded here:
CubaseAutomapClient64.zip (56.9 KB)

Hi,
Would you describe your settings to me, running automap with CB12? I have downloaded the .dll from your comment and copied it to Files\Steinberg\Cubase 12\Components, but I just can’t make it work properly.
I can use the Modwheel and keys, but Transport, Mixer and all the buttons are not recognized by Cubase. The VSTis like Kontakt and Opus do recognize some controls, but not all of them.

Thank you in advance!

So basically I had the opposite problem, with MIDI messages not working at all when in Automap mode (I’ve got a Zero SL MKII) but transport and mixer control working just fine. Also, whenever I reinstalled Automap, the whole thing would work perfectly, but only until the next reboot, which was kinda weird and I thought that this was related to some writing/editing on some core files of Automap, either by Cubase or something else (I’m no tech, but I tend to solve things empirically, by intuition).
After some uninstall-reinstall thing, here’s what I did:

Uninstalled and cleaned everything related to Automap and Novation software/drivers (also those .dlls in Cubase’s “components” folder);

Factory reset of my Zero SL MkII, just in case (and I have my templates and presets stored in the computer, so no big deal at all);

Installed Automap 4.12;

Now, after you install Automap, you should have a “C:\Program Files (x86)\Novation/Automap” folder, and there you should find a “CubaseAutomapClient64.dll” file.

Just because of that strange behavior I explained above, rather than copying this file into the “components” folder, I created a shortcut from the original location (that’s “program files (x86)\novation\automap”) to Cubase’s Components folder. Then, I made automap to be launched at startup, and re-added “automap” as a device in Cubase, and guess what? All good on transport/mixer/midi…it just works!

Hope this works for you as well!

1 Like