C8 and omnishere


After updating to WIn 10 i lost my autorization for Omnisphere. After contacting their support they told me to run cubase as admin to be able to authorize and run it… And well, it worked. But running cubase in admin mode means that drag and drop wont work and also read that there are some issues back and forth regarding j-bridge.

Does anyone know how to solve this or?



I would expect, you could run Cubase as an admin only once, just to authorize your Omnisphere again. Once it is authorized, you don’t need to run Cubase as an admin any more. Or am I wrong?

what do you mean “drag and drop wont work” ?

Yes… it goes back to unregistred again… its kind of wierd since it worked in win7 just like you mentioned. So i belive its someting with 10 and and how cubase handles admin mode and drag and drop… im totaly blank now, normaly i manage to figure out a way for it to work but not this time…

hmm… or Spectrasonic but they say that their stuff works as it should… but again… one of the 3 aint handling things as it should…

With DRAG AND DROP i mean that dragging either midi files or wave files into current project from a folder dont work under admin mode.

But thanks for you tip :slight_smile:


Oh really? :-/

Yes, it goes back back. But i found a workaround even if i dont like it and that is to tweak the UAC from regedit in win 10. By setting it to 0 all works, both drag and drop and the autorization for Omnisphere. Now i dont have to run cubase in admin mode but it kind of sucks to have that setting.

I go with that for now and hope someone comes up with a better solution… Thanks for checking in and help


Yeah likewise to get JBridge and drag and drop working I need to totally disable UAC in regedit, which means I can’t use any Windows Metro apps and my system is less secure. Thankfully I don’t need those apps but still, it would be nice not to have to totally disable UAC.

Why? Its the most annoying Windows addition ever!

First thing that got dis-abled when I installed Win7 and I’m sure it would be the same for Win 10, if I decide to upgrade.

I always had it on no notifications, since they were annoying, but even on it’s lowest setting which has no notifications it still does at least provide another layer of security, as opposed to it being totally off which I have to use now. Also, the photo viewer and calculator are now metro apps so I can’t use them. I had to install a third party fix to get back the Windows 7 ones.

Not a big issue by any means, but it would be nice if it worked without these workarounds.