Cakewalk Plugins issues in Cubase Le 5 - SOLVED!!!

Hello to all,

I am new to this amazing world of MIDI/music software.

I have Cubase Le 5 and I have Cakewalk Dimension Pro plugins in the Cubase Le 5.

When it comes to recording, I have issues with some instruments from the Dimension Pro.

First of all, my equipment;

AMD Phenom II Quad Core 2.80 Ghz
8 GB Ram
1 TB Hard Drive
Tascam US-122MKII Audio Interface
M-Audio KeyRig 49 Midi Controller
Cubase Le 5
Ableton Live Lite 8
Cakewalk Dimension Pro VST Plugins

Now the issue.
I’ll explain.

Let’s say I choose a violin, and when I press down on a key for 2 seconds, the note is played for as long as I hold it down, for 2 seconds. Which is normal. And when I tap the key for like 1/10 of a second (like a drum pad), the note is played for 1/10 sec. Normal again.

But when it comes to recording a track, when I tap the key for 1/10 sec, I hear the note played for 1/10 sec.
So it should record a note of violin for 1/10 second. (like a tap)
But actually what it records, it is a note as if I pressed and held the key for the whole duration of the note which is like 2-3 seconds depending on which instrument…sometimes it is for like 5 seconds depending on the instrument.

In recording mode, I hear what I want to record, like a tap.
But when I playback what I recorded, I don’t hear a 1/10 of a second of violin, I hear the violin playing as if I held down the key for like 2-3 seconds (the whole duration of the note).

When I go to Ableton LIve Lite 8, with the same plugins (Dimension Pro).
I do not have this issue.
So I thought this should be something from Cubase.

Does anyone understand my issue, if so, can you please help.
If you do not understand my issue, let me know, I will try to explain more.

Thank you in advance,


Hi Frank

Sounds like you may have “quantise” turned on In Cubase- which defaults to a specific time period when it recieves a midi command…for example, if you have quantise set to one beat and Cubase recieves a note on and note off message within that period, it will record the note as one beat long, irrespective of how short the note press was.

Hello to all

Thank you celtsound for taking the time to respond to me!
And thank you to everyone who tried to find a solution!

I did found the solution though.

Basically, I had to download update patches from the Cakewalk website.
I first downloaded a Dimension Pro 1.2 update patch.
Then I downloaded the Dimension Pro 1.5 update patch.

You have to do it in order.

The solution was solved after I installed the Dimension Pro 1.5 patch.

While I was there, I installed 3 expansion packs as well.
So now I have even more sounds to work with.

Not only the issue is solved, I also got more sounds!

I guess everything happens for a reason!

Thanks to all,