[CAN-13042] Multi out instrument tracks still broken after disabling PLEASE RESPOND STEINBERG

I tested 9.5.41 - and as far as I can see - problem remains.

A short recapture of how it become for me
#1. this works as workaround - making a small Project template, with the instrument and a bus on adjacent tracks.
Like for superiordrummer2 on instrument track, 7 stereo out on track 1 and a bus for it on track 2.
Select those two tracks and export selected tracks(to archive).

This can be restored sucessfully - before in Cubase 8 up to now.
Order of everything is as saved - in mixer with outs and project windows with automation.

#2. This is a failing example - from an existing project superiordrummer 7 outs on instrument track is on track 29, and bus on track 33.
Select those two tracks and export selected tracks(to archive).

This become mockup when restored. Outs in mixer are scrambled order of outs, and same on automation lanes in project windows.
Out 2 and 3, snare and hihat in my case, end up last instead of first.
Two extra automation lanes as well are created - become not track color(red in my case for instruments) but gray.
These two gray extra something can be marked and removed, so not sure what cubase these are - some kind of inputs or something.

If this propblem is what I think it is - this order of outs become mocked up and have to do with order of original tracks save - I think problem with disbaled tracks remain as well. I guess some kind of loosing track of order of things that belong together when something is lost in between.

I have similar result when making a BlueCatAudio Patchwork loaded with four midi vst plugins of piz, and two samplers for a brass section.
Workaround with making special project where those to be saved - are adjacent to each other - makes all the difference.

So not taking random project and just save random tracks from it to archive - and try to restore later - I have a workaround since Cubase 8.x.
So preparing special project when what you save with tracks adjacent to each other - it seems to make a difference.

Now you can place group channels(busses) anywhere and less of a problem to make a workaround, but worse if to take from a project where busses are placed in separate folder - then track order will be far apart and think problem bigger.

So I say this is not working as intended yet.

I just read manual about how it works - where you need to restore from multitrack preset, must be already the same kind of tracks there.
Thanks for your comment, I will look into that.

I had a bad start with track presets in elements 5 years ago - where you could not remove a preset once inserted, so stayed away from it all.
You could only replace with another preset.

I don’t usually use Import Track From Project, but had cause to do so just now. Even that doesn’t work - it imported the 2 audio tracks I needed but broke an instance of Battery 4 in the project, citing missing inputs when I imported those audio tracks. Identical behaviour on two attempts.

The entire import engine is stuffed really, whatever is mucking things up I think is code that is shared among many different functions. I hate to make one of those “grass is always greener” posts, but Pro Tools’ session import is rock solid, as are Track Presets.

Just an ordinary day working in Cubase 9.5.41

-duplicated tracks
-renamed tracks
-mixed up tracks
-disabled tracks

Track import - that’s bad - I thought it was supposed to make a new track version if a conflict of some sort.
When track import from project came - I always thought they were going to build on that and fix routings and stuff in upcoming version - but seems not.
Walk away from track archives, kind of.

They sort of worked away form rack instruments - and supported more and more for track instruments - so thought that newer approach would be continued to be improved, like track instruments eventually got multi outs etc.

Avid already dropped windows 7 for PT, so not an option for me really. PT and Cubase had some similariries in how you got visuals while adjusting VCA’s and could work on that for a while until decided you are done. And PT has real context sensitive help to get by easier.

Sonar is a really great daw though, but not much headroom until I hit the ceiling for what I want to do.
Reaper is so lean on the system - nothing compares. Some things though, a bit off.

I’m pretty sure they are not going to fix it in V10 because the support plays stupid with me again.
Like they hear about the problem for the first time

ok v10 is almost here and looks like nothing was improved on that front.

did anyone check out the Cubase 10 update logs?

To keep a good enough education level of support agents - is hard, I think.
That they are more eager to respond, than realize it’s above their head and to raise to next tier of support - to really help.
They seem to think they didn’t do their job if they didn’t do all the responses.

The only vendor of today that has top notch support is Waves, they know this.
I always had a solution, every time.
Last time, 18 months ago - a piece of mess Waves Central - that screws up install - I finally got the offline installer to download.
But they hang in there - that’s gold.

Waves has this Studio recording software, not a real daw, I think - but if Waves made a daw, I would get it for sure.

I’m indifferent to what’s in C10, as I realized that mixer snapshots does not include automation - but seems to delete automation if it’s there - how is that for implementation?

Hey hey everyone - I’ve read a post elsewhere that says that this really has, in fact, been fixed in Cubase 10 despite the absence of documentation to support it. Steinberg claim to have fixed it in 9.5.41 according to a rep, but no-one here has made it work and there’s nothing in the changelog there either.

I’m planning to install C10 at the weekend, but if anyone can beat me to it to test on C10 then all the better. If it is fixed then fireworks and cartwheels obviously, but keen to know if we need to make our Archives / Disabled Tracks from scratch or if they open existing ones ok.

I’ve read that on VI aswell, pretty skeptical at this point
please do try and let us know!

this is Steinberg speaking. No excuses: this needed to be fixed a long time ago. I’ll talk to the team how this could be solved.


That is very welcome, Matthias.
Please keep us updated

Hallelujah! Thanks hugely Matthias!

Chiming in to show support for the cause! Thank you Matthias!

I will update to 10 as soon as this thread confirms resolving this. Thanks…

This is the fix I’ve been looking for in every change log of every Cubase update. Hope this can be resolved as it’s driving me crazy.

Thank you Matthias !

I’ve created a small zip file of a .cpr and two track archives to try to help get the problem nailed down by Steinberg. There’s a detailed READ ME of how I got the problem to manifest, and some screen grabs to illustrate.

Note - the .cpr was created in C10 Pro and includes stock plugs from the release, so it won’t work on C9.5 or earlier. I wanted to do this to eliminate the fixes that Steinberg have already done from the equation. I was also able to generate the fault using only Steinberg plugs, but the first failure occured for me with the one third party Track Archive, a Battery 4 .xml.

Interesting that I didn’t get the fault at first, but once the fault first appeared it was then impossible to get rid of. This chimes with my experience all round - on a first round of tests things may well appear fine. But close, restart, come back to it… and like a bad nightmare it will be there waiting for you…

If anyone wants to test to see how it is on their systems, the file is here - https://www.dropbox.com/s/td22vr0kping4fa/CAN%2013042%20test%20material%20GR.zip?dl=0 . Please do read the READ ME though, and don’t forget that first tests may very well be deceptive.

Very happy that this is finally getting some attention. Thanks Matthias!

I’ll make a recap of my experience with track archives as well as a separate description.
I’d say exactly the same issue as disabled tracks internally in handling - something gets out of order - as it does for disabled tracks when restored.

#1. Not creating a good track archive
a) from a fully featured project I save superiordrummer instrument track as track 29, and a group channel for it on track 33 and save those two as selected tracks.
b) as restored you get outputs scrambled order, sometimes not colored as instrument track(red in my case) and a bunch of extra automation lanes which in some cases can be removed, sometimes not. If colored gray they could be removed, if colored red as instrument track - it could not be removed.
c) in some versions of Cubase I also got popup dialog about missing tracks etc when restoring an archive.

#2. Workaround that seem to create ok track archive
a) make a blank project, and just insert superiordrummer and a group channel for it - and save those two, track 1 and 2, as selected tracks.
b) as restored into any project seems to work ok, all named, ordered and colored and no extra automation lanes.

So there seems to be confusion how Cubase handle things and keeping what belongs together in order.

any workarounds I came up with always ended up with the same mess sooner or later
there is no workaround at this point sadly.
even considering all the different ways you can import the track into the project - they all fail with the same exact symptoms