[CAN-5870] MIDI Devices Setup Import Not Working

Windows 10

  1. Run Cubase 8.5.20
  2. In MIDI device Manager - Export Setup
  3. Close Cubase 8.5.20
  4. Run Cubase 9.01
  5. In MIDI Device Manager - Import Setup

All entries in the list show as ‘MIDI Device’ and not the true instrument names. Importing the file only imports one entry shown as ‘MIDI Device’.

I confirm the above for win 7 too

Can also confirm on Windows 7. Can also confirm that even when you do finally get your synth devices recognised again using the Midi Device Manager, an Export - Import under Cubase 9 still exhibits the same ‘Midi Device’ behavior as mentioned by “The Elf”.
Very disappointing as I spent many (many) hours manually editing midi_device.txt files so all my external synths and expansion cards had all patches mapped within Cubase

Temporary Fix: If you still have them, copy your edited synth_patch.txt files into the %appdata%/Roaming/Steinberg/Cubase9_64/Scripts/Patchnames folder (See attached image). On startup Cub9 adds the synth_patch.txt files to the list of possible Midi Devices you can install under the “Install Device / Add Midi device” menu. At least then you can re-add your devices under the Midi Device Manager and re-map corresponding midi in/out’s.

If you no longer have the synth_patch.txt files… it’s a world of pain editing new ones… Sorry.

Great information there, dac!

I will admit that I long ago gave up on trying to create patch maps for all my devices, but I’m inspired to knuckle down and create those text files to carry them forward for the future.

I have exactly the same issue. When I copy the patchname XML files from Cubase 8.5 to the corresponding folder in Cubase 9 and then try to import them using the MIDI Device Manager, they associate with a ‘MIDI Device’ that has no outputs. I’ve tried creating devices with the names listed in the XML files prior to importing to no avail.So what’s the secret to getting these to work?

@amoon56 - I suspect it’s actually the XML format that has changed between 8.5 and 9.0.1 and is now causing the incorrect reading of the file - Although, given a 9.0.1 export/import fails with the default 9.0.1 files, it may actually point to another issue within Cubase 9 (?).

The files I am referring to are actually *.txt files. These were originally found in the Patchnames directory in earlier versions of Cubase and are simple flat text files that get loaded when starting. These define a midi device name (so you can identify your device) and it its associated patch names in the device. For example my JV series synths have optional expansion boards. I used the vanilla JV-1080 text file from Steinberg then added my specific expansion card details/names. *Note The forum site will not allow me to add .txt files to my post. If you want to see these an example of the files, you will need to email me direct and I’ll send you the two file I am referring to next… The david_JV-1080_GM.txt file is a vanilla Steinberg created JV1080.txt file with my World-Card and 60’sn70’s Keyboards expansion cards added. The second file is a simple Lexicon MPX550 Reverb that I created so I could select internal patches via their patch names using the Midi Device Manager in Cubase.

You can create these files for any midi device (Midi Keyboard/Synth/Midi Switchable Effects Processor) but you need to follow the naming layout so the call in Cubase is translated into the correct Midi Device Name call. Some of it is a bit of trial and error until you know where the first Patch Name is stored via a midi-call to the device. Once you get one started it’s not too hard… just a lot of typing names and numbers… :-/

Hope this helps.


I’ve just hit this problem as well. I thought it must be an issue with the .xml files I exported from Cubase 8.5 but even if you export a setup from one of the predefined MIDI devices in Cubase 9 then try and import it, you get the same behaviour.
I can’t be asked to redefine my external devices from scratch so I’m back to using 8.5 until this gets fixed :imp:

Same troubles with Elements 9.0.1.

I have the very same problem and opened a support request.
However, after 5 days and unable to reach support by phone (BeNeLux) I am still waiting for a solution.
I also have many devices and many maps for my mixers.

I wouldn’t hold your breath, Lanny. I’m sure they will fix it, but even at best it may be weeks away.

Same Problem here. I really don’t want to type in about 1000 patch names again.

I found a work-around (for Windows).
Close all programs.
Open the “Run” command prompt by pressing the Windows logo key and R on the keyboard simultaneously. The Windows key is located between the keys Ctrl and alt.
(To open the command prompt on Windows XP select ‘Run’ from the Start menu.)
In the command line of the ‘Run’ window, enter this path: %appdata%/Steinberg
Copy the file named “Midi Devices.bin” from the previous version of Cubase.
Go back and open the folder that is named after the current version of Cubase and rename the Midi Devices.bin to something logical.
Paste in the original Midi Devices.bin file.
Open Cubase 9 and your Midi Device names should be there.

Well done, mate. Works a treat.

Brilliant! This worked a treat for me too :smiley:

MixterRader, As I said before this works for my previous set-up copied now from 8.5. However, when again exporting the set-up in Cubase 9 and importing the export the issue remains, so I will keep my ticket with support open. Thanks for the work-around for now.

Same problem here. Having a fair number of old hardware synths, the midi device panels are important to me. In fact it is one of the main reason for choosing the pro version of Cubase. Quite surprised that the bug exists because nothing has changed in the device panel part of Cubase for many many years so I am sure the source code for it is untouched. They probably use some newer XML library that can’t read their own xml files.

I would actually love if they brought the device panels into the 21st century since it all looks and feels very old-skool.

Anyway, the bug is probably (hopefully!) already on Steinberg’s fix list but I have created a support ticked for the issue anyway. Fingers crossed this is fixed in 9.02

I have the same issue although mine goes a stage further. I have tried to create a device from scratch for the Roland DS88.I just started out with a couple of presets from a couple of banks to make sure my bank select and program change info was working. I set the outputs correctly, but whatever I do,when I go to the track inspector ,it will not show or let me select my named presets. So as not to lose what I had done, i exported as xml etc, then when I reloaded I had the issue you are all saying.
Wonder if anybody can suggest what I might be doing wrong for it not to show in the track inspector?
This is not a good start for this old timer that’s just returned to Cubase since Score v3 and previous Atari :slight_smile:

Same issue here. Bug confirmed.

The workaround only works for me partly. I still cant see/select the patches. The editor though is now there. Does anyone also have this problem?

Workaround doesn’t work for me. I can’t get any midi devices working on my C9.