Can Dorico trigger two different playing technique in one rhythmic position by key switch change?

I am writing a harp piece with Dorico 5 Pro. The top notes are harmonics and bottom notes are ordinarily plucked. I created expression map with natural harmonics and key switched to designated note in Kontakt. The whole top and bottom notes play harmonics, instead of only top notes. How can I fix this?

Does Dorico expression map allow each note on the same position play different articulation ? Trying to solve this last 3 days without success.

When I try this with Noteperformer, it correctly separates top and bottom notes with correct articulation. This mean that there should be a way to fix this.

I would appreciate any suggestions.

You should use independent voice playback, so that each voice on the harp can be played back by different instances of your harp sound. That way, each voice can use independent key switches etc. as necessary.

That sounds like the solution. How do I turn on independent voice playback?

In Play mode under the Track Inspector tab, select your harp and click the button…

Thank you so much!

I enabled independent voice playback that created several instances for different voices. Then, the whole computer slowed down with beach balls everywhere.

My computer is M1 Max 64Gb of memory and 8Tb of hard. I was using 2.6Gb Berlin Symphonic harp with Kontakt from Orchestral tools.

I barely managed to be able to save the project.

Is there anyway I can make the system more efficient?

IVP will create a new VST instance for every voice used on that instrument. You might want to rationalise your use of voices. (I’m surprised a change to a single player caused a major change to performance)

I somehow figured out what the problem is.

When I activate independent voice playback, it separates my music into 9 instances of Kontakt. The VST Audio Engine CPU usage suddenly jumps up to 130%. Whenever it is about 100%, the the screen freezes, beachball appears. I increased audio engine buffer size to 2048. Then the CPU usage of VST Audio engine is about 50-60%. The music plays rather smoothly.

But, when I click anything on Kontakt, the CPU usage jumps to more than 100% again. Kontakt CPU meter is always quite low all through this high CPU usage of VST Audio Engine.

When beachball appears after CPU jumps more than 100%, it is impossible to do anything. I have to force quit each time. Any suggestions to prevent VST Audio Engine jumping too high? The highest value in audio engine buffer is 2048. I would not mind going even higher if there is any option.

I kept reading other threads and found that ASIO guard might be the issue.

I turned it off in Advanced setting, then the VST Audio Engine activities stays around 50-70% regardless of what I do.

If someone has similar issues, I recommend to increase audio buffer to maximum and to turn ASIO guard off.

Is there any disadvantage by turning it off?

Having activated independent voice playback, it would be a good idea to rationalise the plug-ins used in your project. You almost certainly don’t need nine instances of Kontakt. Consider assigning the voices that don’t have conflicting techniques to the same channel on the same instance of Kontakt, then unload those plug-ins. Consider loading the harp patch into separate slots in a single instance of Kontakt so that you only have one instance of Kontakt in the rack.

I thought nine too many, too. How do I assign independent voices to a different channel of Kontakt? Is Independent Voices editable?

See if this will help.

You do it by changing the channel value in the Routing section of the Track Inspector panel in Play mode, where you enable or disable independent voice playback and specify which VST instrument should be used.

I will try thank you.

I managed fix some voicing of my harp piece and was able to clean up finally leaving 2 upstem and 2 downstem voices. Then when I enabled indipendent voice, Dorico separates 4 original voices into 8 instances of Kontakt. I don’t seem to have control over this. Am I right? I think it is up to Dorico to separate my original voices into how many as it wants.

Then, the system then slows down with VST Audio Engine easily goes over 100 % of CPU. When Audio Engine CPU usage is too high, Dorico in Activity Monitor shows red letter saying it is unresponsive. I cannot save anything and have to force quit Dorico.

The funny thing is when VST Audio Engine is using 130% of CPU power, I can still do all other tasks with my MBP M1 Max without any problem. Only Dorico becomes unresponsive. I think VST Audio Engine probably uses only fraction of the CPU power, and the rests are still operable.

Is there any way I can allocate more CPU resources to Dorico and VST Audio Engine? Did I accidentally turn off any multi-thread or audio engine boost feature?

The solution maybe to use a different Playback Template. Select the ‘Silence’ playback template and then load a Kontakt instance into the first slot. Choose that instance for any number of voices after you have invoked Independent Voice Playback. If you need an additional instance of your harp VST, simply load another Kontakt instance into the second slot and assign which ever voices to it that you want. The ‘Silence’ template will NOT automatically load more instances of whatever VST you are using, no matter how many voices you create - much better to manage all this manually and as it becomes necessary.

Thank you. I will try that!

I realized that my current system, quite decent though, could not handle Kontakt in Dorico as multiple instances or multi timbral instrument. When I do that, VST Audio Engine constantly crashes.

Instead, I connected VEPro with single instance of Kontakt with 8 loading of Berlin Symphonic Harp in the rack. Finally, Dorico could do everything smoothly again. Because these are two separate decoupled apps, Dorico did not slow down or crash at all. VEPro maxes about 50-60% of CPU power except when it stores the projects.

VST Audio Engine goes down less than 10% of CPU usage while not playing Kontakt in Dorico.

Why didn’t I do this earlier?

It was a great learning experience. I hope Dorico engineers will improve the VST Audio Engine in near future, so that we can easily work with Dorico without involving expensive VEPro.

If anyone else has similar issue with Kontakt in Dorico, I highly recommend running Kontakt in VEPro. I was very frustrated that I could not save my work while using Kontakt in Dorico because of VST Audio Engine crash.

Thank you everyone who advised here.

1 Like

If VE Pro works smoothly in Dorico and Kontakt does not, logic seems to point out that it is Kontakt’s engineers who need to work on their product… Am I wrong?

It seems to be VST Audio Engine (of Dorico) issue, not Kontakt issue. Kontakt runs well in other hosts such as Logic, Ableton, Kontakt Kontrol etc. With the same amount of processing, VEPro’s CPU usage is about 50% of Dorico.

I guess because Dorico’s main purpose is notation, not music producing having some issue with VST engine is not a deal breaker. I switched to Dorico September this year. I think Dorico is the future. I have high hopes.