Can I refresh MIDI devices without restarting Cubase?

Once in a while I launch Cubase and load my template (takes about 5-plus minutes) only to realize that I forgot to first turn on my MIDI keyboard. Here I am ready to work, and I’ve got to restart the program and reload the template.

Is there a way to refresh MIDI devices without restarting? I found an old post on another forum from way back in 2009 that had the same frustration and question, and the answer then was no. Is this still the case?

1 Like

http://www.steinberg.net/forums/viewtopic.php?f=182&t=54145

You been ‘avin’ a wee bit too much o’ the creature, lad?

There is a way to do this , go to your midi connections and untick the “In all midi” boxes and then re-tick them ,that should remake the connection to your midi devices

1 Like

This can’t work as only items that Cubase has already recognised will show up in the list. If your keyboard wasn’t switched on there is no entry in the list and so no box to tick.

1 Like

No creatures involved, simply providing a link that answers your question.

For Windows O/S: Here is a way to restart a USB midi device that was plugged in before starting Cubase and was running properly but somehow got disconnected during the session.

Once you discover your USB is disconnected and not working do the following procedure:

  1. Shut off your USB midi device
  2. Re-plugin your USB midi device
  3. Turn on your USB midi device
  4. Go to Devices>Device Setup…>MIDI Port Setup
  5. Find your USB midi device in the list and uncheck the box “In ALL MIDI” this will make the state “Inactive”
  6. Recheck the “In ALL MIDI” box to make the state “Active”
  7. Hit OK

Ah, thank you. Sorry, for some reason (like, maybe, blindness!) I didn’t see the link, only your curious signature line.

Windows only problem…
Even though I finally figured out and posted the procedure for restarting a USB midi device that was connected prior to starting Cubase there is still no way that Cubase will recognize a USB midi device that you want to connect after Cubase is started. This is just lame IMO and Steinberg should be embarrassed that their professional grade software cannot do this.

Regardless, I started a thread in the “issue reports” forum a few days ago. If you want this fixed please show your support for the thread at the link below.

http://www.steinberg.net/forums/viewtopic.php?f=184&t=55869

I find it hard to believe that every user running Cubase on a Windows system would not want this fixed but the recent thread started by Finsonic in the feature request forum shows over 1700 views and only 117 replies. 1/2 of which are replies that just muddy the issue. Sad really…


Regards,

2 Likes

Thank you so much for this!! I don’t know if I have a failing keyboard or what but this is a lifesaver being able to reconnect without restarting cb.

FYI… this issue has been fixed in Cubase 9.

Regards :sunglasses: