Can not access the effect added to my fx channel to change preset

I’ve created an fx channel with reverb as the effect. After I choose a preset and close the Reverb, I can no longer bring it up to change presets. A few years back and versions of Cubase, someone suggested Alt and double click. Another to Right Click on name and from drop down, choose Edit. Can’t see that available in the dropdown. I’m using Cubase 11 Pro. Any ideas how to do this. I’m running out of things to try.
Thanks in advance,
Michael Warren


Do I understand you right, the plug-in window doesn’t appear at all? Or is the plug-in bypassed or deactivated?

I add the FX track and the reverb on it.
. When I first add the reverb the GUI appears and I can choose my preset and amount of reverb. After closing it, in the mixer I can see the FX track with the reverb I chose. I can send an instrument track to the reverb and control the amount of reverb on the track. Now if I want to change the reverb preset, I can’t get back to the reverb interface. I hope that I’m explaining it a little more clearly. Thanks for your interest in this problem.

I think my answer was too long. I have no way of getting back to the plug-in window or interface after closing it. So it does work for the original price that I choose.

when you click on the little “e” in the mixer channel where the FX is loaded:

you should see the reverb plugin in the inserts for that channel and then you can click on the little e for that plugin and you should get to the plugin interface to change any setting you like:


Click the “e” button on the left side, when you mouse hover over the Insert slot in any window (Inspector of Project window, Insert slots of MixConsole or the Channel Settings Window). What happens if you do so?

I may be doing something wrong. In mixer I click on E, channel settings come up, but I don’t see the reverb in inserts… I added it as an fx channel and then add send to kontakt track so that each additional track I add can use the same reverb, but with different settings.

3 After clicking on TrueReveb in channel settings back to mixer
4 using send to fx from track


You just routed the Send to the FX Channel, but you didn’t Insert the plug-in in the FX Channel yet.

OK, at 6:30 AM, I deleted the TruVerb FX track. Then created a new FX track with a different reverb. That appeared in the INSERT part of the Channel Settings. I then clicked on the E and the GUI opened for the Reverb. Don’t ask me why it did not show on the original track. Thanks for the suggestions and pictures. I now know what to look for or see missing in the future. I really appreciate this forum and you users that make it productive for new Cubase Users.
Thanks again,
Michael Warren

1 Like

Does anyone really sleep in this forum?