Can Not Register Use eLicenser

Hi, I buy H1 Zoom and it bundled with Cubase LE and Wavelab LE in download version,

I already follow all instruction but can’t register as a full version software.

The message in windows said “The Currently installed version of eLC is to old.” , I already download the new version from website but it also doesn’t work.

Please help me to solve the problem, thanks.
elc.jpg

Hi and welcome,

Did you try to uninstall the eLicenser (completely) and install it again from scratch, please?