Can someone help me solve this problem (Drag and Drop Audio)

Hello, This is not a Steinberg bug but a problem at my end and it’s killing my workflow.

I upgraded to windows 10 in the summer from Windows 7

Since upgrading, I’ve lost the functionality of dragging and dropping audio into Wavelab and Cubase from folders.

I am using an admin account, I’ve tried changing the security settings to no avail.

Id really appreciate it if someone could give me any pointers on how to fix this.

I am using an admin account

This should not be checked.

Thank you. This was currently checked because its the only way I seem to be able to open Wavelab.

If I don’t run as admin, I get the Wavelab loading screen, then it disappears and doesn’t open the app, but seems to be running as a system process. So the only way I seem to be able to get the app to open is with this checked?

So the only way I seem to be able to get the app to open is with this checked

Not normal. If you are obliged to do so, this means you must have something not correct on your Windows system. But I can’t know what.

No worries thanks for letting me know. Would you or anyone suspect what I should look into that might be the issue? I run a full-time studio so I cannot reinstall windows or apps at this time.

Hm. This is odd that you cannot do this. It works here, no problems. I wonder, does the
‘Import - Audio File’ (the long way) work? It seems to me that if this works then the dragging and dropping should work also.

I have to wonder if your particular Template is compromised? Create a new Template or use the stock Steinberg ones in C10 and see it this works here?

I would actually like to know how you “upgraded” to Windows 10 - was it “in place” - meaning right over top of your old Win 7 install - or did you wipe the drive and start from scratch?

Upgrading in place always has issues of some sort - many only show themselves as super odd obscure issues - and this one sounds odd. Properly installed and configured - a Windows 10 user should NEVER need to run any app as Admin.

If you need to actually force this (Run as Admin) - the app itself needs work and is not compliant with Win 10 standards. I have run Wavelab through at least 4 versions over the last 10 years and have never needed to run as Admin.

VP

If it happens in Wavelab and Cubase, and creating a new admin or standard user in Windows and trying Wavelab and Cubase under the new user doesn’t make any difference, I found an very old Audacity discussion that yet sounds very similar. Showing the last post with the solution, the user had to go back to a previous system backup, which I’m sure you’re not going to want to do. But they suspected a .net windows update or one of the listed programs as the culprit.

https://forum.audacityteam.org/viewtopic.php?f=16&t=62864&start=20#p167412

But in troubleshooting they did find that running in Safe mode didn’t exhibit the problem. Don’t know if Wavelab or Cubase run in Safe mode, but if so… maybe worth trying to narrow down.
Also disabling ALL in Windows Selective Startup solved the problem.

None of this gives a working solution but might narrow things down.

PG, maybe a dumb question at this point, but does that mean if you do Run as Admin it kills the ability to drag and drop? I’ve just read that’s what happens with Cubase.

if you do Run as Admin it kills the ability to drag and drop? I’ve just read that’s what happens with Cubase.

Same with any application. This is a Windows security protection: you can’t drag from a low privilege application to an application with higher privileges. Same with Copy and Paste.
Open a “door” to an application with lower privileges could be exploited by hackers.

Again, Windows controls that.

Some better explanations:
https://superuser.com/questions/59051/drag-and-drop-file-into-application-under-run-as-administrator

Thanks for the explanation and link PG. Sad to say, I didn’t know.

All good and well. But running at lower previdges the apps don’t even work. Pretty sure its something to do with elc

BTW, make sure to use this option:

Yes thats alway’s been checked, Pretty sure it’s something to do with the e-licencer. I used to get an error, something like syncpos.exe not working. Then admin prev needed changing on elicener and around that time these problems started.