Cannot activate cubase le getting error message about e license

HELP! I have installed the Steinberg download assistant on my PC (windows 10). I have downloaded my free version of CUBASE LE using the activation code given me on the paper the came with my Zoom R8 after creating a Steinberg account. After selection the products with in CUBASE LE you get to the point where you have to activate this. You enter the code and then you have to download the eLicenser control center. This then asks for your activation code that is generated by Steinberg to your email as the Your new activation code(s) HOWEVER every time I enter the activation code into the eLicenser control center. I get this error message saying "currently there is no eliscenser connected to your computer to download the license to. And it talks about a friggin USB which I dont have nor have ever had! Then it talks about a soft e license option that you have to contact the vender of your product to obtain. ??? What is this talking about? Is this something Zoom R8 should generate? Okay WHAT NOW???


Make sure the Soft-eLicenser Number had been created. You can see it in the left panel of the eLCC application, below the HDD icon.

If you don’t see it, use the eLCC Helper to generate one, please.

I did try to generate one it said to uninstall and reinstall but it didn’t seem to fix the problem. I have another look at it


Can you see the Soft-eLicenser Number in the eLCC application, please?

If you are going to install the eLCC Helper, I would recommend to uninstall the eLCC first and then install the Helper. Make sure, you install it as administrator, please.

tried all that and no no Soft e License comes up at all.

I am thinking as this was a free down load with a code I got from the zoom R8 purchase some how it might be faulty. I guess if I was to buy a product online direct from Cubase then perhaps it would come with an eLicense and I would not have this problem?


It’s definitely not related to the fact, this is OEM (LE) version.

Have you tried to install the eLCC Helper as an Administrator, please? Did you get any message while installing eLCC Helper, please?