Cannot get ARIA and other VST 2.x plug-ins to appear

I have done everything by the book (Doricos help center), written my whitelist, checked the spelling of the plugins, checked that they’re in the right folder etc., still the vst2 plugins won’t show up in Dorico. Anyone else experienced the same thing in latest update 1.2.10.139.
It worked in earlier versions…frustrated.
I’m on Mac.

Which family of VSTs, aobelund?

ARIA Player, MachFive3, Addictive Keys, Addictive Drums

Could this thread help?

Thanks Mark, buy I’ve tried all that. It’s some old threads and you don’t need GUID numbers anymore. I followed the https://helpcenter.steinberg.de/hc/en-us/articles/206899770 by the book but it doesn’t work for me :cry:

For what it’s worth, this has worked for me and gets Aria to work in Dorico.
I haven’t tried Addictive Drums in Dorico yet.
vst2whitelist.zip (207 Bytes)

Thanks Derek, it didn’t work either. This is so strange, I’ve tried everything even deleted all the preferences. Maybe Daniel or someone else at Steinberg have a solution…

Anders, it really should be the case that provided you have a file called vst2whitelist.txt in /Users/your-username/Library/Preferences/VSTAudioEngine, everything will work. The contents of my file at the moment are:

ARIA Player VST Multi
CFX Lite
Kontakt 5 16out

And ARIA etc. show up just fine for me.

But the plug-in files (bundle) need to reside also in Dorico’s (VSTAudioEngine’s) search path, otherwise it won’t “see” them.

Have a look in /Library/Audio/Plug-Ins/VST , that is one of the locations that the audio engine will look for.
Or have a look at /Users//Library/Preferences/VSTAudioEngine
There is a file called Vst2xPlugin\ SearchPaths\ VSTAudioEngine.xml
listing all the VST2 search paths.
You can also edit that file, I posted a description already quite some time ago.
Please use the search function of the forum.

It’s crazy, everything seems to be at the right place (VSTAudioEngine…etc.) but it might be the search path but I can’t figure it out. The Forum deny to enclose the XML-file, Ulf, so here is a link to it if you can see some discrepancy there.
https://www.dropbox.com/s/t5pbddghg6usmqe/Vst2xPlugin%20SearchPaths%20VSTAudioEngine.xml?dl=0

And what is the path to your ARIA? Could you also please choose from Dorico’s main menu Help > Create Diagnostic Report?
That will create a zip file on your desktop, please send it to u dot stoermer at steinberg dot de.

Ulf, I’ve solved it! I made a new textdocument and changed the encoding to Western (ASCII) and - voilá - it worked. Obviously the preferences are sensitive to that. Thanks anyhow for your effort, maybe this can help someone else!