Cannot open Wave device for recording..?

I am having a great deal of difficulty getting Wavelab 9 to operate consistently with my MOTU 16A interface in OS X 10.11.5.

Yesterday I began a sampling project to record mono 48kHz 16-bit .aiff files. When I pressed record, I received an error message:

“Cannot open Wave device for recording. Are you sure your audio device supports the currently specified sample rate and/or bit resolution?
Check also if the input of the audio device is in slave or auto-sync mode.”

I checked all of my settings and restarted the computer. After reboot, I opened Wavelab 9 and was able to record normally, edit and playback audio for the remainder of the afternoon.

Today, when I go to continue my project, I can no longer clear that message, even after various reboots, including restarting the audio interface. Additionally, when trying to playback any audio, even yesterday’s samples(!), Wavelab reports back “The VST audio connections are not valid. Check the VST Audio Connections dialog.”

The only change that I made to my system between yesterday and today was rebooting the interface!

To troubleshoot, I have already done the following:

  • logged out and restarted the computer
  • turned off completely and restarted the computer
  • rebooted the interface
  • turned off completely and rebooted the interface
  • made sure the sample rate for my device and recordings were all consistent
  • checked for an updated version of Wavelab – found version 9.0.20(!) and installed
  • checked for updated MOTU AVB drivers… no updates, still using the latest.
  • reset all of the MOTU clock source, sample rate and buffer settings
  • uninstalled Soundflower, just in case the extra audio drivers on my system were creating some issue
  • deleted Wavelab 9 preferences and started fresh – no change!
  • tried to reinstall the coreaudio2asio package for El Capitan that fixed issues with the previous version of Wavelab. Installation would not progress beyond the “Installation Type” step (the Install button will not ‘illuminate’ to continue.

I must admit, I am perplexed by this sudden behavior, and my work is at a standstill until I can get the interface to be recognized again. Any further ideas to troubleshoot? All of my other software – Ableton Live, Logic Pro X, Adobe Auditon, all recognize the interface and can record fine. (Yes, I could switch to Audition to continue my project, but Wavelab has better tools for what I am trying to do and my workflow.)

Any advice would be greatly appreciated!

Maybe your audio device is externally clocked, hence WaveLab can’t set its sample rate?

Do you have the motu mixer app active?

Thanks for the quick replies, guys!

@PG – the 16A is internally clocked. Made no changes anywhere to the clocking, and as I mentioned, everything was working great 24 hours ago.

@mroekalea – I’ve tried running Wavelab with the mixer app open AND closed with the same result. Even read somewhere that someone was having difficulty when their web browser window was open so tried closing everything else on my machine except Wavelab.

everything was working great 24 hours ago.

Could you use the Mac Time Machine to step back?
Are you using 9.0.20?

Yes, I updated to 9.0.20 after not being able to get things up and running with the previous version. Let me revert and see if anything changes…

UPDATED Went back via Time Machine and restored version 9.0.15. Same issue. If I switch to Built-In Audio, Wavelab works like it should. Not sure how/why it broke for my MOTU.

BUMPED for Solution

Been racking my brain trying to figure out why I was unable to playback and record and seem to have “fixed” the issue by reverting back to the last version of non-beta drivers for the MOTU AVB series. What’s interesting to me is that I was able to work with Wavelab normally for an entire day with their beta driver before encountering the issue.

It’s especially strange because the AVB devices are supposed to be class-compliant, but the beta driver is one that was “re-written from the ground up” and it appears to have broken some functionality with Wavelab (and possibly other Sternberg software). I will report that information back to MOTU’s beta team for further testing.

Anyhow, what I noticed last night may be hard to explain but the I/O the driver ‘reports’ to the system is flexible, depending on device settings. As an example, I can set the number of input and output streams between the device and the computer via the MOTU Discovery app, anywhere from 1 to 64. My normal configuration uses 34 inputs and 32 outputs, but to troubleshoot the issue I was having with Wavelab failing to even detect the 16A, I created a new 2-in, 2-out configuration. Even with this simple setup – all routed and clocked properly – Wavelab would consistently “fail to open the Wave device”. I should also note that the names of all of the inputs and outputs in Wavelab (and in Audio MIDI setup) were inconsistent with what was indicated on my routing tab for the device. Not sure where it was pulling the I/O labels from.

On the other hand, with the “old” driver, Wavelab now shows all 64 inputs and outputs selectable in the VST Audio Connections preference pane, regardless of how many I designate available in AVB Discovery. This makes more sense to me for stability of operation, as the software doesn’t have to figure out what my personal driver configuration is for the unit. I just have to remember what instrument is routed to which channel for recording.

In the end, it is back working for the time being, which I am grateful for. I have no other audio editing software that is more ideal than Wavelab for this particular sampling project I am working on, which involves thousands of very short samples. I’ll keep an eye on things nonetheless and report back if there’s any more weirdness.

Has anybody found a solution… I have had this message for a couple of weks and cannot record anything on either wavelab 6 or Wavelab Elemnts 9.5 which i just downloaded audio out is OK but not in. Windows 10 and has been fine till now. I have also tried to connect a Behringer usb soundcard which works on another computer but same message on this one.

Do you have some kind of utility for soundcards effective (like ASIO4ALL)?

Your error messages says that your soundcard is locked by another program, ASIO capable program needs exclusive acces to the soundcard device!
SO disable everything which could in any way lock or obtain ownership of your soundcard. Also mixers like banaanmeter are know to cause this kind of issue.