Cannot Record Midi Events with Groove Agent 3/ Cubase 8.5.15

Hi, I’ve been trying for the past hour or two to record midi events with Groove Agent 3 and Cubase 8.5.15.126. I’m on a Mac 10.10.5 and I am using JbridgerM 32/64. I am running Cubase in 64-bit mode. As well, I tried it in 32-bit mode and still got no luck recording GA midi events.

I have GA set to “record live to host” saved as the default. The green “RUN” button is on and I can hear the real-time audio playback perfectly.

In the past, in order for me to record midi events I would have to choose GA as an Input AND the Output.


But when I choose the inputs, it only lists GA as an “output” . Please see the attachment.
Groove Agent Input choices.png
ON the outputs it has GA as only midi in. See attachment.
GROOVE AGENT OUTPUTS.png
This doesn’t make sense to me.
Can anybody please help me this? I’d greatly appreciate it. Perhaps the JbridgerM is not compatible with this version of Cubase?

Or maybe I’ve got the routing done incorrectly? I’m not that used to Cubase 8.5. Maybe I’ve missed something.

PS, I did try to open GA in another blank project and the same problems occurred.

Thanks Everybody, Jeff

Ok… look at these items:

  • Make sure you are recording to a midi track
  • Make sure you have “All midi inputs” chosen as the track input routing (in the inspector section)
  • Make sure you have “Groove Agent 3” chosen as the track instrument (in the inspector section)
  • Make sure the “M” (mute) button is not active on the track you are working on.
  • The “green” button is not “Run”. It is the “Read” function for the associated automation track. So disable it.
  • Enable the actual track “Record Enable” button (looks like a round sphere, should turn red)
  • To the right of that is the “Monitor” button (looks like a speaker). Enable that.
  • Hit the record button on the transport panel. You should be recording stuff and hopefully you can hear it while recording.
  • When playing it back, disable the track “Record Enable” & “Monitor” button.

I am assuming that you have your VST connections input and output buses set correctly.

If this doesn’t work please provide a screen shot of your Device setup and vst connections (both input and output tabs) screens. Also list some basic computer specs and what device you are using to record GA3 with. Also, it would be good to know what audio interface you are using.

Good luck

Regards :sunglasses:

Hi Prock, thx for the quick reply. I’ll do as told and let you know. Thx Jeff

Hi Prock, It’s still not working. Here are some answers to your instructions. Please find pictures attached. Many Thanks Jeff
DEVICE SETUP.jpg
OUTPUTS.png
INPUTS.png

  • Make sure you are recording to a midi track (YES)
  • Make sure you have “All midi inputs” chosen as the track input routing (in the inspector section) (YES)
  • Make sure you have “Groove Agent 3” chosen as the track instrument (in the inspector section) (YES)
  • Make sure the “M” (mute) button is not active on the track you are working on.(YES)
  • The “green” button is not “Run”. It is the “Read” function for the associated automation track. So disable it.

(What I meant is the “Run” button on the GA Gui, not the Read button. I made sure Read was not enabled)

  • Enable the actual track “Record Enable” button (looks like a round sphere, should turn red) (YES)
  • To the right of that is the “Monitor” button (looks like a speaker). Enable that.(YES)
  • Hit the record button on the transport panel. You should be recording stuff and hopefully you can hear it while recording. (YES)
  • When playing it back, disable the track “Record Enable” & “Monitor” button.(YES)

It still is not recording midi events when GA is playing. BUT, I can turn off the Run button, Hit record and manually input notes on my keyboard and it records the events.


Hardware Overview:

Model Name: MacBook Pro
Model Identifier: MacBookPro10,1
Processor Name: Intel Core i7
Processor Speed: 2.3 GHz
Number of Processors: 1
Total Number of Cores: 4
L2 Cache (per Core): 256 KB
L3 Cache: 6 MB
Memory: 16 GB
Boot ROM Version: MBP101.00EE.B0A
SMC Version (system): 2.3f36
Serial Number (system): C02HX4BBDKQ4
Hardware UUID: F0F25406-25EB-5F8B-905B-A2B1E39E702B

I don’t have the same audio interface as you do but the pics show that your vst connections (inputs and outputs) are wrong. The output bus should be set to show as stereo, device port should (probably) be rear Right and rear Left. The inputs should be set as mono, device ports front 1 and front 2. So the inputs will be 2 separate busses.

Not sure if this is going to help your issue but… Maybe, especially fixing the output bus (fingers crossed). :wink:

After you change these settings please report back if it helped or not. If not, hopefully some others will chime in.

Regards. :sunglasses:

Hi Prock,

From the pic I sent of the outputs, it says that it is Stereo. Under the Bus category, it says “Stereo Left ,Right”. The Device port is showing Front Left (Stereo Left) and Front Right (Stereo Right) only. There are no other choices.

My inputs under the Bus category are “Stereo, Left/right”. Device port “Front left, Stereo in Left and Front Right, Stereo in Right.”

And you say:
The inputs should be set as mono, device ports front 1 and front 2. So the inputs will be 2 separate busses.

Ok, I’m not sure how to route GA after doing that.

I’ve don’t recall having this problem before. I will open another project where I use GA and see if it is working and what the inputs/output are and let you know if it works. Thanks Jeff

Again… I’m really not sure if the vst connection issues will help with the GA recording issues but… let’s look at things one step at a a time.

On the VST connections menu input and output tabs have you clicked on the “+” button? Maybe more will show up?

(I think) I know this…

As you confirmed the outputs are showing as on the front. Except for the earphone connection, I don’t believe there are any other outputs on the front of the UA25. If my audio interface was connected like that I would not be able to hear anything from my projects through the monitors or earphones. Typically the stereo output bus is set up as a stereo connection on the back of the audio interface where you connect your monitors. Even if you don’t have monitors connected the signal will still get to the earphones.

The (2) combo inputs on the front of your UA25 are mono inputs when used separately. You can probably set them up as stereo inputs but… have you ever connected a stereo device to both of them at once? Most use those connections as mono. As an example connecting a guitar to the 1/4" jack or a mic to the XLR portion of the combo. If you do use them as described in my example you would have to add them as separate mono buses (hence the 2 line items).

As you mentioned, please do open another project where all is working and check the VST connections to compare for differences. Maybe somehow a project (or your template) was mistakenly changed.

Hopefully you will find a project that does work properly. If you do, backup the project and rename it something else. Then use that as a test to try and record from GA3.

Regards.

HI Prock, thanks for your help. I’m still not getting things working. With regards to the inputs/outputs, I have never had a problem. I usually use the default audio setup. I don’t record audio often at all.

It seems to be an issue perhaps with Cubase 8.5. I’m going to try to open a project in CB7 and see if that works. I tried opening other projects where I used GA with CB8 but it still doesn’t work.

As I mentioned, in the past, in order to get midi events to record I would have to put GA in the slot where it says “All Midi Inputs”, and have it in the bottom slot as well.

As well, I have written to the developer of JbridgerM to see if there is an update . I’ll let you know if things work in CB7, Jeff

Fixed it!!!

I contacted the guy that developed the JbridgerM for Mac and he told me to the issue could be resolved by opening Cubase 8.5 in 32bit mode. Groove Agent 3 is now recording midi events.

Also, make sure that you have GA in the Input slot AND the Output in the Inspector. On to music.

Thanks Prock for your help! Jeff

Glad it is sorted :slight_smile:

Regards