Cannot record with new USB interface

Im using cubase 5
win 10
my new USB interface: U-PHORIA UMC22.

I’ve set it up like i think is correct. I get output but cannot record. The mic light the signal lamp on the interface so it works fine.

What can be wrong? See some screenies below:

I would try it with the driver that’s made for it.

What do you mean? The ASIO4ALL v2 is what is made for it, at least that’s what behringers homepage tells me to download for this interface.


Never heard of that.

So you downloaded ASIO4ALL USB Audio Driver?

Usually manufacturers write drivers for their hardware and ASIO4all is a generic driver.

Anyway, you show pics of your cubase setup but not of the ASIO4all setup.

You have to connect your hardware to the ASIO4all software in their configuration software somewhere.

Never used it but I’ve seen pics of setups where you can use more than one interface with cubase.

Yes I got recording to work now! (changed the setting in the config for ASIO4ALL).

Problem is if i switch to these drivers, now the USB interface have to handle output also. Right?

My other ASIO driver is the computer on-board audio, which is what is connected to the speakers. Can I not use these for output if I have the new ASIO selected in cubase?

I thought ASIO 4 all could connect to 2+ devices.

So you could record from one device and play back on another.

How would a USB mic work? I’ve never figured that out.

Should be something in the asio4all docs about how to set that up.

But this is something i set up inside cubase right? Here i choose output and input.

In the asio4all there is just an option to choose either asio4all or the generic asio driver.

No, only thing you can do in Cubase is select the driver like ASIO4all.

It’s got to be in some configuration for ASIO4all where you set that up.

That’s what I would guess. What do you see available in VSTconnections?

VSTconnections is where you set up your input and output buses but it can only use what the selected driver makes available.

If i choose the ASIO4ALL driver I can only see that (USB audio codec 1/2) for outputin “VST connections”. And these give only output sound through the USB box itself (headphone jack or audio jacks on the back) not through the audio jacks on the back of my computer (where my loadspeakers are connected).

What happens when you hit the button that says control panel?

That should open the settings for ASIO4 all.


I go to the setting panel for ASIO4. I now understood I can tick (“activate”) both the USB interface and my onboard sound card. Now I can choose my new USB interface for input and my old audio card for output (in VST connections in Cubase).

Thanks for your help!