cannot remove bar rest from voice.

pls see attachment.

why won’t the bar rest in the 2nd measure go away ?


What would happen if you switched the voices in that measure to the rest was not in the primary voice?
Have you tried using the Edit > Remove Rests command?

if I do a swap voice in the bass clef of the second measure, the rest disappears and if I swap it again, it remains gone.
I have this all over the place though… (ctrl-a, remove rests was a disaster).

I don’t understand why It appeared in the first place considering the notation options disallowed it.


Do not use Remove rest after a Select all command, unless you really want to get rid of all the rests ! Selecting the bar rest and Remove rest should do the trick. The “long” equivalent to that would be to select the last red c (first bar of your picture) and activate the property Ends voice.
Is your file an XML import? This could explain why everything in it does not follow your notation options. The behavior after swapping voices shows that now Dorico has taken over any override in that bar and the Notation Options rule.

Thanks, but it is not an xml import. I did not override anything. I do not understand why these rests are appearing when the policy says to not do them.
I have dozens of them all over the upper voice of the bass clef

The “ends-voice” property stops it, but it just continues the next time the voice comes in.
I don’t think it is it the intent that this needs to be removed manually all the time.

Can you attach the score that shows this problem? Otherwise, it’s hard to say more than “well, it doesn’t do that for me”.

There is a command in the context menu that could solve this — although I’m not completely sure. Save your document before you do it. Then click on a downstem voice note (the purple one) of the bass staff and Context Menu (or Edit Menu) > Voices > Default stems down. I hope this will help. If it does not, you still can revert to the saved document (or undo).
I’ve been editing a lot of orchestral scores lately, and believe me, the demanding part is always to add bar rests (when two players share a staff and only the first plays), but I do not recall having to get rid of rests… I wonder why you have those that appear.

Did the OP apply the policy before or after entering the notes and spotting the measure rests? The policy may not be retroactive; if that is the case, then Edit > Reset Appearance may apply the policy to existing material.

Edit-Reset appearance and default stems didn’t do anything.

I did change the policy (notation options) midway. In fact, I notice that new music doesn’t have the issue.

I would think that the change should be retroactive… sometimes you don’t know until after working with the score that you want to make that alteration.

I attached the example (401 KB)

Upstem voice 1 is NOT an additional voice - it’s the primary voice. Therefore the “rests in additional voices” rule doesn’t apply.
Either use Remove Rests or Swap Voice Contents. Both will work.

Indeed-- you have to account for at least the first voice, alternatively, you could click on the last pink note of the first measure, select, “ends voice immediately” and that should do it as well.

“ends voice” worked for a while… after playing around with it, it got into a mode where whenever I turned the slider to on, it auto-slid back to off… I didn’t understand that.

What is a “primary voice”, and what does it matter ? The (bass clef) upper voice (tenor) stopped in measure 2. It would not be correct to make the D in the second measure (baritone) the tenor line. It is the tenor line that is the additional voice that the policy should hide the rest in.
What does “starts voice” do ? Doesn’t the voice start when you simply enter music there ?
I guess the intent of the start/end voice slider isn’t clear to me… I also don’t see the “after barline” option making any difference.

I tried adding some more bars and then went back to the notation options. These later added implicit rest do appear/disappear as I toggle the “bar rests in additional voices” entry; however that rest in the second measure never gets removed… I think this is a bug.

Here… try this… take the second measure of the example and copy into the (new) 4th measure… no rests.
I don’t understand the inconsistancy.


The global option controls whether complete bar rests are shown in a voice. But if a voice starts in the middle of a bar, you might not want the preceding rests in that same bar. If you select the first note (or rest) that you want to see, “Start Voice” hides the preceding ones.

Similarly End Voice can hide rests if the notes in a voice end in the middle of a bar. It can also remove any following whole bar rests, if the global option was set to display them.

Suppose the attached example was a piano part. You don’t want either of the two rests. Selecting “start voice” on the 8th-note G will hide the rest before it. Selecting “end voice / after barline” on the 8th-note F leaves the quarter note rest in the same bar but removes the green whole-bar rest in the next bar. (With the default engraving and notation rules, the blue whole-bar rest is for the other voice is underneath the green one). Selecting “end voice /immediately” also removes the quarter note rest.

I don’t think I’ve seen than with END voice, but it does happen with START voice when you have used that voice previously, but didn’t “end” it.

The nice thing about Edit / Remove Rests (when it works!) is that you don’t have to search for where to put the start and end voice properties yourself, Dorico does that for you.
voice start end.png

The primary voice is the voice that Dorico uses for general measure rests in empty bars. It’s not necessarily one continuous voice, but in otherwise empty bars there MUST be a primary voice or Dorico doesn’t know how long a bar is (and thus can’t space barlines effectively).

We’re getting into pointless semantics here.

Here’s what happens if I use Remove Rests:

And here’s what happens if I change the voice of the note from Downstem Voice 1 to Upstem Voice 1.

In black and white, the ONLY difference is that one has the stem point up, and the other has the stem pointing down (and you can always override that by flipping the stem direction). As a pianist, it makes absolutely no difference to me whether the stem is up or down.

Imagine, for a second, that this note was an E rather than a D - the result would be the same whether you changed the voice or removed the rest:

Here… try this… then take the third measure of the example and copy into the (new) 5th measure… rests.

It’s not inconsistent - Dorico’s saying “you used that voice in bar 1, and you used it in bar 3, so you must want it present in bar 2”. Wherever you last used the voice is where the voice ends.

thanks for taking the time to explain this. I understand the start/end voice better.

I think the issue may be the concept of a “primary voice”. I did not see that defined anywhere in the documentation.
I assumed that when there is only one active voice in a measure, it is the primary voice.
However, based on your explaination, and playing around with the editor, I infer the “primary voice” is the first voice entered (seems to be the top voice of a staff).

Hence, if you are entering a SATB score in 2 staves and you have “omit bar rests” selected in the notation options, only the alto/bass rest would be automatically omited; the sopr and tenor must always be manually adjusted (and here swapping the voices is not correct as it would be for piano).

It’s also interesting that if you do “swap voices”, twice, it removes the empty voice from that measure and won’t go back to the original way.