cannot write file error

I’m still getting the cannot write file error, even after deleting the .txt file that should resolve the problem.

Any other possible solutions?

What .txt file are you speaking about?

I found the workaround online and tried it… I will try and post the link.

Regardless it didn’t work and I re-instated the original .txt. file

here is the link to the workaround.

https://www.steinberg.net/forums/viewtopic.php?t=125401

Unless I am mistaken … that link does not tell you delete the text file.

Rather, it says to make sure this location or file is not read-only.

Is this your issue?

pretty much. I actually did both and neither worked.

Have you activate the ransomware protection feature on your PC, and if you have, did you add Wavelab to the list of allowed programs?

No ransomware activated. Still not working.

Do you have another app open/running in the background? ProTo*ls for example can ‘take control’ of disks.

Also, do you get this message on all disks you are writing too?

its not a disk issue, its writing to a .txt file in the cache that isnt working right.

I was thinking ‘disk’ in the context of permissions … because (from your description) WL thinks it is unable to write the .txt file to the cache location C:\Users[YourName]\AppData\Roaming\Steinberg\WaveLab Pro 9\Cache Which kinda feels like a permissions issue?

I’ve set it from so it isnt “read only” and it still wont write. I even made a new .txt file with the same name and it won’t work.

Puzzling. Are you running your WL session on the same disk as the system drive? If so, try running a session on a second drive. See if the problem persists.

Also,are you able to share a little more on what your computer set up is.

Does it happen when you open and close audio files, or when you open the program? Or when you’re doing something else?

This has the same error message:

https://www.steinberg.net/forums/viewtopic.php?t=97989

Yes, only when opening and closing files.

I did try that setting, in fact it was already set like that.

Ok. If it’s happening when you open a file, (and the same to the person in the thread you linked), wouldn’t it have to be trying to write to some file other than the lru.txt file on file open ? (That file doesn’t seem to be affected by file opens, as far as I can tell.)

What files are written to when audio files are opened? Maybe some companion file, or a log file?

Looks like I’m wrong about that. It does show a different modified time on file open. So maybe the problem still is the lru.txt file.

If I delete the tru.txt file, Wavelab recreates it when I open an audio file. If I close Wavelab and set the tru.txt file to Read Only, it stays that way until I open an audio file in Wavelab. When I do that (open an audio file), Wavelab apparently changes the flag so it’s not Read Only, and it writes to the file. When I look at the attributes again, it’s no longer Read Only.

I’ve never gotten the error message you’re getting, even when I set it Read Only, because Wavelab just changes it back to writable.

Have you considered resetting your preferences?

I usually just rename the settings folder (so I can go back, or move custom presets to the new folder), and Wavelab makes a new settings folder on startup.
https://helpcenter.steinberg.de/hc/en-us/articles/206618850-Troubleshooting-for-Cubase-Nuendo-and-Sequel-on-Windows#preferences
(under INITIALIZING PREFERENCES - for Cubase and Nuendo, but it’s the same for Wavelab).

If it doesn’t help, or you want to go back, you can delete the new folder and rename the old folder back to what it was. If it does help, you’ll need to copy any custom presets from the old folder to the new one.

So I was instructed by support to remove my app data in the hidden folder, then start the program. It rebuilt my database and all is good.

Simple solution.

thanks everyone.