Cannot write in read view (Apple Pencil setup?)

Just got a large screened iPad Pro and Dorico for iPad has come alive for me!

I’m using Apple Pencil only as a more precise finger alternative. I’d love to see “Scribble” integration but that’s already been discussed.

My problem is that in read view I can’t use the handwriting; not with Apple Pencil nor with my finger. Not recognizing even though pencil tool selected. Do I need to turn off “Scribble” or other setting change?

To be clear, even in the pencil tool I can only scroll. I just tried various Pencil settings included disconnecting Pencil and still only scrolls in Read view.

Thanks for your help!

Alex, Dorico for iPad has no Apple Pencil support - except you can use it instead of your finger to tap areas or shift scrollbars. There are no more functions possible with the Apple Pencil.
[edit] please read Daniels reply below!

You should be able to use Apple Pencil in Read view, provided you have an active subscription or you have the Lifetime Unlock in-app purchase: a little icon for the pencil will appear on the toolbar, and you should be able to tap that, which will show the various controls in the Read view toolbar, allowing you to then annotate the pages to your heart’s content.

Alex, do you see the toolbar button for the annotation tools? Are you able to access the annotation toolbar?

Thanks Daniel. I do have a subscription and can see the toolbar. I click the pencil icon, it shows the tools, I select pen or highlighter… but it won’t draw. My finger or pencil just scroll the page around.

Very curious. I’m not sure what could be going on there. I’ll ask my colleagues in the team if they have any idea how we should proceed.

I can confirm this behaviour. Also the +/- buttons dont’ work.

I wonder whether this could be related to the iPadOS version, maybe? Alex, Nickie, what version of iPadOS are you running?

I can confirm this. At least with the finger I will just move the page. The plus and minus buttons do work (for moving to the next or prior page). ipadOS is 15.5

Mine is 15.5. The latest. And it is the 2nd gen. iPad Pro 12.9”. And Dorico is

Klaus, it’s expected that your finger will move the page around. The interesting question is whether or not you can annotate the music with Apple Pencil: even if you activate the annotation tools: the annotation tools will not work with your finger. They will only respond to Apple Pencil (or another similar pen/stylus input device).

I understand Daniel. It’s time that I unpack my Apple pencil… I bought it last December and it is still awaiting in its box… If there is some useful function for Dorico it makes even more sense :slight_smile:

Belatedly replying here. I’m running iPad OS 15.5 on a 4th generation iPad Pro 12.9”. Dorico app is up to date. Thanks for looking into this - the problem persists today after updating OS.

I’m still seeing this problem: iPad Pro (M1) with iPad OS 17.1.1.

Pencil just scrolls the page, with annotation tools selected. Lifetime unlock is active (I can use Engrave mode, and everything.)

I’ve just tried this again myself on both of my iPads (iPad Air 4th generation and iPad mini 6th generation), and it’s working as expected here. I’ll ask my colleague with the (non-M1) iPad Pro to give this a try and see if he’s able to reproduce the issue on his device.

My iPad Pro 2nd gen is now on iPadOS 17.0.3 and the annotation tools do work as expected with the pencil now.

I think I’ve worked out the issue. If the layout is in Galley View when you switch to Read, then the annotations don’t work. (Even though Read mode shows the Paged View. )


Spot on! I can confirm this.

Thanks for figuring out the circumstances under which this goes wrong, Ben. I can indeed reproduce this myself now, and we should be able to fix this in the next Dorico for iPad update.