Can't attach note (comment) to rehearsal number

I clicked on one of my rehearsal numbers, then hit option-C to add a comment to it, and Dorico opened the comment box and let me type, but when I hit OK, the comment disappeared and was never recorded.

Possible bug? I’m in

Just wondering whether they have to be linked to a note, a bar, not a rehearsal number… I think this has come once before…

Just tried on my Macbook (12.5) and DP 4.2.1092 and found that you have to be in note input mode, so you can see the caret. It works OK then. ie double click the rehearsal mark

Thanks @RobF - that worked - however I’ll still raise it to the Dorico team as a bug. Particularly since I first typed my whole comment, clicked OK, and the comment was entirely lost.

I think it’s a bit like having to have Insert active when changing meter to get the correct number of beats - took me ages to figure that out! By the way, great idea to have comments tied to rehearsal marks, really useful. Thanks for the tip.

Comments can’t be attached to system-attached items. It should really prevent you from creating a comment in the first place in that situation. It’s on my list of things to look at.

1 Like