can't batch process with IK Multimedia plugins

Hello,
I need to batch process files with IK Multimedia’s Amplitude but the exported files are silence with glitchy clicks.
As soon as I remove the plugins or uncheck it, the batch process works fine.
I have tried to close the program and reopen, to create a new project, to change the processor options, to change the plugins’ settings, but Wavelab still doesn’t want to export the files correctly. It behaves exactly the same way with other plugins such as T-Racks CS Classic Comp.
The plugins work fine with Cubase, Ableton, and Logic, even with non real-time exports.
Any idea of why this is happening?
thanks
Florent

How does the plugin behave in real-time Wavelab? In a montage or in the master section with a single wav file? Is it a 64-bit or 32-bit plugin? VST2 or VST3?

thanks!
IK multimedia plugins work fine with Wavelab in real-time in an audio montage. The issue appears when using them in the batch processor.
they are 64-bit plugins, not sure if they are VST2 or 3. How do you check this?
https://www.ikmultimedia.com/products/amplitube4/index.php?pp=at4cs-specs

it looks like there are two version of the amplitube plugin: vst2 and another vst3
when using the vst3 version, it works fine

the problem is the other IK multimedia plugins seems to be only available in vst2 and they are still problematic
is Wavelab batch processor only able to process VST3 plugins?

The batch processor can work with both VST2 and VST3 plugins.
Are you using the latest WaveLab, 9.5.35?

yes I am