Can't change wrong players - NotePerformer

Maybe someone can help… after months I’m still getting this.

-The attached pic shows how NP automatically creates many instances of mixers with repeated instruments that are not even on my score (a regular symphony template… I don’t have ten flutes!).

-NP is just assigning the wrong sound (a Flute) to my Viola staff.

-If I try to manually change that Flute back to a Viola (Setup–Players–Viola–Change Instrument) nothing happens. The menu does not appear.

-If I duplicate the Player, with the aim of copying the “corrupt” Player’s music to it… it doesn’t add it to the score. It just renames the existing Player’s staff (from Viola to Viola I). All the layouts and flows (just one) are selected.

I’m sure something’s wrong. I think I’m doing everything by the book.

Any ideas, anybody?

Thanks

Have you tried re-applying the NP Playback Template from the Play menu?

1 Like

Or what if you change the instrument from within NotePerformer? In the NotePerformer window you can click on the instrument name above the fader and from the pop-up menu choose a different sound.

@Derrek Yes, I have. Nothing.

@Ulf Yes, but that manual override is not desirable. If I have to reset the playback template for any reasons, all those changes will be lost. NP is supposed to do this automatically. All those NP instances with a gazillion flutes, the wrong instrument assignment, the impossibility to change instruments in Setup… Something is not working properly.

Right. But was this an xml import or was the original instrument a flute? Changing the player in setup mode and then reapplying the NP template still doesn’t fix it? In theory, if you do both of these things, then it should be sorted. (I can’t quite tell from your previous replies if you’ve done both of these things in this order.)

@Romanos401 This may have been an XML a long time ago, then tweaked extensively. But the original instrument was never a flute. I have tried many times to reapply the NP template (first apply Silence, then NotePerformer). Strange, because every time I get a different number of NP instances (sometimes 5, sometimes 3…). But I still can’t change the instrument of the player afterwards. Not for any of the strings. Oh, and the flute sound is still there, instead of the viola.

I suspect there is some little thing lurking in the code as a result of the original xml… there have been a good number of oddities reported as a result of xml imports over the last three years. I’ve experienced weirdness too, so I suspect this is the culprit. Sorry it’s such a pain!

I see. So, given the fact that working on your DAW, then exporting an XML to create the score on a notation program, accounts for a great percentage of users’ workflow… shouldn’t this be solved by now in Dorico? If an XML renders your software useless, whats the point?

Well, this isn’t normal behavior. Could you post a stripped-down version of the project here?

Have you gone to the Setup mode and used Change Instrument to reselect the Viola to make sure the pointers in Dorico are pointing to what it says it is instead of what a prior XML may be concealing? Then reapply the NP Template.

Could you send us a Dorico file of the piece, just enough measures to have the Viola Play so we could hear for ourselves and check out solutions?

Thank you, guys. I insist, I can’t use Change Instrument to reselect the Viola. It’s not doing anything, the menu for the instrument change won’t open.

I see the only way here is to post or send over the (stripped) piece, which at this time I’m not ready to do, for privacy, with all those applications logs and preference files. I appreciate the concern, though.

The change instrument dialog won’t appear if there’s a change to the staff count anywhere in that instrument (divisi in section players, staves added or removed on solo players).

You may need to add a new viola and then copy and paste the content across (preferably with all signposts turned on).

1 Like

sorry if this is a stupid question, but are you sure you are running the latest version of Noteperformer (3.3.2 I think)? And of Dorico?

@pianoleo Thank you for the hint. I had tried already to create a new player, as I mentioned on my original post. Unsuccessfully too.

I have made a couple of videos showing what I encounter when trying to add a new Viola to my score. I’ve tried two options:

A) I add a new player and assign it a Viola sound. Instead of appearing as an extra instrument at the bottom the score, the existing Viola staff changes its name from “Viola” to “Viola I”. So, no new staff to copy notes to.

B) I add a new player and assign it to a random sound (Alpenhorn). It doesn’t appear at the bottom of the score. Or anywhere.

This may be normal behavior, maybe I’m doing something wrong. (Still, I wish I didn’t have to do this in order to get NP to play the right instrument).

Sorry for the poor quality, it’s the export from .mov to .mp4 (can’t upload .mov)

I’m running 3.5.12.1066 (the very last version messed up my Mojave) and Dorico 3.3.2.

I’m somewhat surprised to see that at the end of the player/instrument-adding process the flow appears to be selected at the bottom of the screen. Generally speaking there’s a special case for flows that originated as MusicXML, which is that when you add a player to the project it’s not automatically added to the flow. Could you try re-selecting the new Viola/Alpenhorn player in the left panel and ensure that the flow is ticked?

Is this what you mean? The flow is ticked, yes:

Also, how come if instead of the random Alpenhorn I assign the Player to a Viola sound, as it should be… it “updates” the Viola name on the score to Viola I? Just the name, apparently, the sound is still flute. And no, re-applying NP template after all this doesn’t get the right sound either…

Wait a sec. You’re looking at a custom score layout that’s called “Everything”. Custom score layouts show the players that you tell them to hold. I’m guessing whatever players you’re adding are going into the default Full Score layout, and are being assigned to the flow, but aren’t being assigned to your custom Everything layout.

Ok, Leo. I understand, thank you.

I’m guessing whatever players you’re adding are going into the default Full Score layout, and are being assigned to the flow, but aren’t being assigned to your custom Everything layout.

Not exactly, it seems the opposite, as you can see in the video below:

-if I add and instrument it won’t show up in the Full Score (which is supposed to be the default I guess). It fooled me, because even though I started from the Everything layout, when you click to add a player it changes to the Full Score layout (you have to be looking to notice). However…

-the Full Score layout won’t show the newly added instrument.

-if I switch to the Everything custom layout, and add the instrument to it by ticking it in the Players list, then it appears in Everything… and in Full Score.

-if I remove the instrument (untick) from the Everything custom layout… it gets removed from the Full Score as well.

I guess the custom layout predominates over the default Full Score? Maybe I’m doing something wrong.

Anyways, I will do this and copy all the music to the “working” player. I hope all this is solved from the NP side too…