Can't erase one note

In the attached image I am trying to erase one of the Cs at the beginning of the 3rd system. If I erase the 1st C I get a quaver rest and the next C is changed to a crotchet. If I erase the 2nd C the entire 3rd and 4th systems are erased. Any explanations really appreciated.

The only thing I can think of, without seeing the project, is the possibility that you’re managing to select the system track along with the actual note, which would go some way to explain the deletion of entire bars/systems.

I can’t think of anything that would explain what you’re seeing when you try to delete the first C.

If you need any further help with this, it would be best if you could zip up and attach the project so we can take a look. Certainly I would try Leo’s advice of hiding the system track (View > System Track).

Thank you for your replies. I have tried hiding the system track to no avail. It is strange, if I transpose the C up one or two octaves, I can change it to a quaver; at the correct pitch or down an octave it cannot be changed.
Attached is a second attempt at inputting the score. (453 KB)

The project as attached looks quite different than your original screenshot, which I guess isn’t surprising because you’ve started again. Perhaps the reason things look confusing is that you’ve told Dorico not to show any rests? Select the semibreve chord of F3/C4/F4/Bb4/C5 on the second system and deactivate the ‘Ends voice’ property.

There’s something weird going on with flags, Daniel. The first F in bar 2 is actually a quaver, not a crotchet, but it’s not showing a flag. Setting Engraving Options > Notes > Flags to Straight Flags will prompt a flag to show here, but setting it back to Default Flags (or resetting Engraving Options to factory settings) will remove that flag again.

edit 1: weirdly it only seems to be upstem flags that are missing. If you take the note above the B line (or just flip it) the flag shows correctly.

Right, yes. Go to Engrave > Music Symbols, select the Flags category, select ‘Combining flag 1 (8th) above’, and click the circular “revert” button.

Moving the pitch of that F quaver (that looks like a crotchet) in Galley shows some weird artifacts.
Image 1: the before photo:

Image 2: after moving the F up to a Bb using Alt-Up. Sorry it’s tiny.

In Page View, Image 2 looks like this - that collection of semiquavers, fermata and repeat text doesn’t show. Nor does the end of the flow. The triplet numbers are back, though.

I removed ends voice and changed the flags to straight flags and it worked. However I had forgotten to change the font to November 2, when I did the same problem occurred and the same solutions worked. The system break before the last C did not work either in the original, now it does.

Pianoleo: I could not get the artefacts to show when I changed to galley view. What is worrying though is that in your image 2, the repeated notes and fermata are from another work. I started this one afresh so don’t know how it happened.

Thank you for all your help, there are another twelve systems to input so I will keep you updated.