Can't get Bluetooth headphone playback (Windows 10)

This topic seems to come up a lot, but most of the replies seem to be for Mac.

I have the headphones set as my output sound device, and other programs – YouTube, iTunes – play fine through the headphones. Dorico still plays through the speakers, though. If I open Preferences | Play | Audio Device Setup, the speakers are the only device available. If I “open device control panel” a few other output devices appear, so for example I can opt to playback through my computer monitor via HDMI (which works, but eww! not what I’ll ever be looking for), but still no option for the Bluetooth headphones. How do I get them to work with Dorico?

I am not sure about the specifics on windows as I am a Mac user, but as far as I know, Dorico uses ASIO driver for playback.
If your Bluetooth device doesn’t support ASIO, you could get the ASIO4ALL driver, which is an ASIO driver speaking to WDM devices (the native Windows driver).

On Windows Dorico comes with the Generic Low Latency ASIO driver and even with that it should already work.
But there are several hurdles:

  1. The Generic ASIO driver in the Device Setup dialog only ever shows one output pair. To see more available output ports, one has to click on the Device Control Panel button, where upon a new little window appears. In the middle of that window is a list of output ports, and the output port you want, you have to checkmark at the front. Normally also the BT headphones shall appear in the list of output ports.
  2. Sometimes they don’t show up for several reasons.
    2a. Dorico is currently set to a sample rate the BT headphone does not support. BT headphones often only offer a very limited set of sample rates. Most commonly used is 44.1kHz, so try first to set Dorico to 44.1k and then check the control panel if the BT headphones turn up in the list of output ports.
    2b. At the top of the Generic driver’s control panel is an option called “Allow ASIO host applications to take exclusive control of the selected port configuration”. Depending on the setting of this option, ports might appear or disappear, so try toggling this option and see if the BT headphones then appear in the list of output ports.
    2c. On Windows’ side there is a similar option, where one can allow or deny exclusive access to a device for an application. That option is to be found under Windows’ Sound Settings > Advanced Settings and then on the Advanced tab.

I use KOSS portaPro wireless bluetooth headphones, but get no audio from Dorico through them. Also, new thing for today, the playback from the computer gets extremely soft when the headphones are connected.

So I wanted to try and change the sample rate, as the headphones should manage 15–25,000 Hz only, but no alternatives are to be seen in the sample rate dropdown menu. Is this normal? Does anyone else have experiences with KOSS?

A sample rate of 25kHz (not frequency range) would be pretty poor for a headphone because you would only get up to at most 12.5kHz through, that would sound pretty dumb. Are you sure you are talking about the sample rate?

Are you using the Generic Low Latency Driver within Dorico? Does your BT headphone turn up in the list of available output ports?

You are right in me citing wrong numbers. (15–25,000 Hz is, of course, the frequency range.)
The Generic Low Latency ASIO Driver is the only driver I can find within Dorico. My BT headphones do not show up.

Then do the following: First make sure that sound comes through your BT phones when using other apps. Then open the Windows Sound Settings (on the taskbar is a little speaker icon, right click on that). Then look for the BT phones device and click on the Device Properties, a new window opens, look for the Advanced Properties, click on it and yet another window opens. In there choose the Advanced tab. There you find the option “Allow applications to take exclusive control”, make sure that that option is NOT selected. Also check for the default sample rate and remember. Close all the little windows and start Dorico, go to Edit > Device Setup. In there set the sample rate to the same value as you just remembered. Next, choose the Generic Low Latency Driver and then click on the Device Control Panel button. Yet another little window opens. At the top is an option called “Allow ASIO host application to take exclusive control of the selected port configuration”, also this one, make sure it is NOT selected. If that is the case, in the middle of the window is a listbox with output ports, your BT phones shall turn up there by now. Make sure that they are checkmarked at the front, then close that window. Also close the Device Setup dialog and reload your project, after that Dorico shall put sound out through your BT phones.

This is the general advice for BT headphones on Windows. I will revise the text and make it available in the FAQ section.

And here the advice for OSX:
First make sure the BT headphones are connected and sound comes through from other apps like e.g. iTunes.
Then start Dorico and go to Edit > Device Setup. In that dialog under ASIO Driver in the drop down list now your BT headphones should turn up. Most likely - and this is important - you will see two device entries. E.g. for a Sennheiser HD 4.50 BTNC the entries “HD 4.50 BTNC” and “HD 4.50 BTNC (2)” are to be found in the list. Why 2 devices? Most BT headphones also come with a built-in microphone, so you can also use it as a headset in conjunction with a smartphone. So the first device is the microphone of the headset and the second device is the earphone. Dorico can’t make any use of the microphone, so in Dorico you always have to choose the second device in the list. So in short, choose your correct device from the list, close the dialog and that should be it, Dorico then shall play out via your BT headphone. We can’t guarantee things to be as simple for every BT headset out there. Post in the Dorico forum if you are having trouble.

Thank you so much for a thorough answer. Surely a wise choise to post this among your FAQs. As for me, I get stuck midways, because there are no alternative sample rates in Dorico: Only 48000. Why can this be?

When you click the “Device Control Panel”, scroll through the list of output ports to make absolutely sure that your Bluetooth headphones are not there. You may have missed the scroll bars, it only shows the first four output ports and you have to scroll down to find more. If you find them, put a check mark there and choose OK and then you should be able to choose them from the “Stereo Output” drop down back in the main “Device Setup” dialog.

What if you leave it at 48kHz and open the Device Control Panel, do you then get the choice for your BT headphones in the list of output ports?
BT headphones might not support all sample rates. With my Sennheiser I also only get 48kHz.

My headphones are stuck to 44.1 kHz, I am afraid. And they simply don’t show up in Dorico (3.5), no matter how I configure them. I’ll contact the producer.

What are your Windows Sound Settings? As described above, go to the Advanced tab and what is the default format set to? Make sure it is 16bit 44.1kHz and also that the ‘Allow applications exclusive control’ option is not ticked. Then start Dorico again and see what sample rates are available there.
I’m sure it will work, it’s just a matter of fiddling around with the settings.