Can't get non-breaking hyphen to match

In the example below, I need a non-breaking hyphen to match the “true” hyphenated lyrics. But every hyphen I can find in the character map is thicker, as you can see. I’ve tried every one I can find, including U+2010 and +2011. I’m using Minion Pro.

Any suggestions as to how I can achieve a non-breaking hyphen that matches? Thanks.

UPDATE: I worked around it by adding the hyphens in Acrobat, but I’m still wondering why they aren’t displaying correctly in Dorico.

I don’t think you can effectively achieve this in Dorico, Dan, because the default hyphen character, which is the hyphen-minus (U+002D, more info here), is also interpreted by Dorico as the command to advance the popover, so you can’t type or paste it into the lyrics popover.

Dan, what happens if you change the hyphen character in Engraving Options to one of the alternatives? Can you still use the alternative in popver text?

Dorico always looks for the hyphen key on your keyboard when advancing the popover, so it doesn’t matter what character you have chosen in Engraving Options.

Yes, but at least they would look the same as the non-breaking hyphens, if you used the non-breaking hyphen character for … breaking hyphens.

Yes, but yuck…

This is a problem I talked about like two years ago…
One solution was to copy-paste from an external editor, but I’m afraid that with the new behavior of paste in the lyrics popover, this is no longer possible. I was able to work with unicodes U+2011 and U+202f two days ago, but I admit I’m not using Minion Pro, and I have tweaked almost all my fonts so that they DO HAVE U+202f available.

Capture d’écran 2019-12-16 à 11.03.27.png

I’m not trying to disgust or insult anyone here, but couldn’t you use a ‘Finale workaround’ and treat the word fragments in verses 2, 4 and 5 as single words with hyphens between their syllables, and then in Engrave Mode simply move the hyphen-space on the right as far as you need to in order to align the hyphens with the other voices? Not a very elegant solution but it does work. I’ve been doing exactly this in Finale for years when setting hymns.