Can't get USB MIDI to work

I’ve connected my Keystep 37 (edit: Also Oxygen 8) via USB and if i press down its keys i can see that Cubase responds (the blue bars that indicates MIDI activity). But when loading a VSTi and putting “Keystep 37” as the input it doesn’t connect to the VSTi, no notes are playing. If I turn on Record and play something (in silence) Cubase doesn’t record anything.

I guess i’m missing a step somewhere, but i can’t figure out what. I’ve tried MIDI channel 1 and also ALL, no change. I’ve looked in the setup and Keystep 37 is set to Active there.

Any ideas?



Double-check the Preferences > MIDI > MIDI Filter, please. Make sure, notes are not filtered out.

I checked, nope, not filtered out. Thanks.

Tried my old Oxygen 8 USB MIDI-keyboard, same thing. This one worked for years, never any issue with Cubase, just connected it and it worked. No go…
Tried another USB Cable
Connected to another USB Port

Solved it. I followed these instructions to make a complete reset of the preferences.

Initializing preferences

Corrupted program preference files can bring your Steinberg program into all kinds of troubles, particularly after installing an update.
Fortunately, refreshing the preferences is quite easy:

** Close all programs.*
** Open the ‘Run’ command prompt by pressing the Windows logo key and R on the keyboard simultaneously. The Windows key is located between the keys Ctrl and alt.*
(To open the command prompt on Windows XP select ‘Run’ from the Start menu.)
** In the command line of the ‘Run’ window, enter this path: %appdata%/Steinberg*
** Locate the folder which is named the same as your Steinberg program, for example ‘Cubase 8.5’.*
** Rename it (for example, from ‘Cubase 8.5’ to ‘xCubase 8.5’) in order to hide it from your Steinberg software. The folder will only be hidden safely, if the change will be done before the original folder name.*